Charger Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I have a 2012 dodge charger police package and I've had a bully dog gt tuner on it with the pre loaded tunes on the car and just recently put of no where the car stalled after putting it into drive and then was saying alot of different errors like service transmission and power steering. But when I shut the car off and unplug the tuner from the car and start the car it runs perfectly fine like nothing happend. Idk if its the tuner its self or somthing else but I've updated the tuner and retried to plug it back in and as soon as I turn the car onto the run position, all the warning lights go one and it does the same thing and also just doesn't even try to start. Somone pls help
Automotive tail & brake light Vehicle Automotive lighting Motor vehicle Automotive design
Vehicle Automotive lighting Motor vehicle Automotive tail & brake light Car
 

·
Registered
Joined
·
2,262 Posts
I would restore the stock tune and see what happens.
 

·
Registered
Joined
·
2,262 Posts
If you returned the car to stock and everything is fine, the tuner...most likely the update you just applied...is the problem.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
If you returned the car to stock and everything is fine, the tuner...most likely the update you just applied...is the problem.
It did it before and after the update. Is it possible that my tuner is like dead?
 

·
Registered
Joined
·
2,262 Posts
It did it before and after the update. Is it possible that my tuner is like dead?
I'd get with tech support. They can download the tuner data and see what's going on.
 
1 - 9 of 9 Posts
Top