Charger Forums banner
1 - 8 of 8 Posts

·
Registered
Joined
·
377 Posts
Discussion Starter · #1 ·
I have been looking on the forums, and...well, no one has made any comments or threads about this before from what I have seen. When I take turns aggressively, my brakes tend to go "squishy", (only way to describe it). I pump the brake once and the pressure comes back. But, every time I take a turn aggressively, the pressure is gone again. Has anyone else had this problem? Does anyone have any ideas on how to resolve the problem? Please let me know. Oh, the pads are the stock pads that came with the car. (07 SRT8)



Thanks...by they way, this forum is too distracting, I meant to post this 2 hours ago...I got caught up reading everything else. So much information, so little time...
 

·
Registered
Joined
·
377 Posts
Discussion Starter · #2 ·
I imagine the sounds of crickets right now...

Hope to hear from someone soon...
 

·
Premium Member
Joined
·
5,466 Posts
Don't know of anything offhand. have you tried the search function on the forum. It works real good on things like that.
 

·
Registered
Joined
·
1,045 Posts
Well check your fluid level, the only time I have had something like this is when I cooked my brakes at the race track :)

If the fluid level is ok, maybe try bleeding them a bit and get some fresh fluid in there.

-R
 

·
Registered
Joined
·
928 Posts
agreed, I dont mess around when it comes to brakes, get it looked at.
 

·
Registered
Joined
·
377 Posts
Discussion Starter · #8 ·
I will definitely be taking it to the dealer, but I was wondering if anyone else had heard or had to deal with this.
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top