Charger Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
571 Posts
Discussion Starter #1
I don't know.

I just know that while I was cruising today in fifth going about 40mph it was... rough... felt like something was grinding hard in the rear end.. only at low rpm, and on the the throttle.

Then, I downshifted, and BANG!! BANG BANG CRUNCH BANG CRUNCH BANG until I came to a stop :cry:

In neutral... no problems at all, it's tranny or.. diff?

No leaking fluids, nothing broken looking.. just can't drive it. I had it towed to a dealership and they're going to look at it tomorrow.

This sucks!

They looked a few weeks ago and said "nope not leaking tranny.. it is SWEATING but not.. dripping, no problem there"

The other day I blew my tire, so I replaced the FRONTS now, (last week I replaced the rears)

The week before I replaced the serpentine belt, and the week before the power steering pump, and a few weeks before fixed an AC problem, and a week before replaced the brakes.

I love this car! Really... ! But DAMNIT this sucks not being able to drive it.

What could this be?

- Jamos
 

·
Registered
Joined
·
571 Posts
Discussion Starter #4
Haw haw!

Just got off the phone with Dodge and the guy said,

"SRT 8? Black? Yeah.. you broke it GOOD! I heard it trying to be moved this morning... wow good for you! hahah, parts on order.. it was the diff. hmm, why would you buy an SRT8? Anyway don't worry it's being taken care of"

I was just... "but.. I simply downshifted.. really" hahah

So ... DMANIT! No car :mad:

I walked an hour and a half to work today in the windy sun. :(

- Jamos
 

·
Registered
Joined
·
571 Posts
Discussion Starter #5
I just called back asking, "What if you covered the cost of the diff, but allowed me to pay the difference towards an LSD? Because this WILL happen again, if it happened this easily... so what can we do to get an LSD in there?"

"Good question James! Let me talk to my service manager and figure out what we can do for you..."

Funny enough this service manager and I get along rather well, so I'm hoping for something positive to come from this!

... awaiting call back.

- Jamos
 

·
Registered
Joined
·
571 Posts
Discussion Starter #6
I just got a call back from the service tech and he said:

"So what are you looking to do exactly? UPGRADE the thing? We have to order the whole assembly for you... but what do you want? What!? They have an open diff!? haha you'd think on a 6.1 they'd put a posi-rear on that... whoa, haha I'll get back to you"

I told him to shut up cause people always make fun of me for having an open diff as it was.... uh yi yi.

So whatever, we'll see!
 

·
Registered
Joined
·
189 Posts
I don't know.

I just know that while I was cruising today in fifth going about 40mph it was... rough... felt like something was grinding hard in the rear end.. only at low rpm, and on the the throttle.

Then, I downshifted, and BANG!! BANG BANG CRUNCH BANG CRUNCH BANG until I came to a stop :cry:

In neutral... no problems at all, it's tranny or.. diff?

No leaking fluids, nothing broken looking.. just can't drive it. I had it towed to a dealership and they're going to look at it tomorrow.

This sucks!

They looked a few weeks ago and said "nope not leaking tranny.. it is SWEATING but not.. dripping, no problem there"

The other day I blew my tire, so I replaced the FRONTS now, (last week I replaced the rears)

The week before I replaced the serpentine belt, and the week before the power steering pump, and a few weeks before fixed an AC problem, and a week before replaced the brakes.

I love this car! Really... ! But DAMNIT this sucks not being able to drive it.

What could this be?

- Jamos
Wow...you must be hammering the s#*t out of that car!
 

·
Registered
Joined
·
1,151 Posts
I walked an hour and a half to work today in the windy sun. :(
Ever heard of a taxi? LOL j/k bro sorry for your troubles
 

·
Registered
Joined
·
2,927 Posts
WHOOOOAH..ok this is the first person I have seen w this problem other than me...please read this thread...hopefully it will help diagnose the problem (if it is the same) compare to how long it took for me...my valve body went w no warning while cruising one day after 12k miles on the car...same exact symptoms...please read this Jamos...
http://www.chargerforums.com/forums/showthread.php?t=30769
 

·
Registered
Joined
·
571 Posts
Discussion Starter #10
it was my diff. i felt weird brakes too -lie they were rusty- but it was thelow rpm... sorry no kboard.. using windows on cscreen kboard.
 

·
Registered
Joined
·
571 Posts
Discussion Starter #11
"Wow...you must be hammering the s#*t out of that car!" ya.. third set of tires in four months :)
 

·
Registered
Joined
·
1,275 Posts
Must be nice to be rich hehehe
 

·
Registered
Joined
·
318 Posts
how many miles do you have on the vehicle when this happened?
Thanks,
cbutler32
 

·
Premium Member
Joined
·
20,935 Posts
"Wow...you must be hammering the s#*t out of that car!" ya.. third set of tires in four months :)
Yep - that'll be the reason for the smashed diff alright.... :grin:
 
1 - 16 of 16 Posts
Top