Charger Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
645 Posts
Discussion Starter #1
Just got my baby back today. Ended up being just over $3000 worth of damage. Here's the pics I took today with my cellphone:





My rental car was a 110 hp Ford Focus...that was rough. No power ANYTHING...no power door locks, windows, no steering wheel tilt. No power under the hood, either...0-60 in about 10 seconds. I didn't realize how spoiled I was!
 

·
Registered
Joined
·
467 Posts
congrats on getting it back. looks like a good repair job. i worked out of town for about a month using a rental honda accord with 4cyl. i had to get that thing revved completely before it would move at all. then I would have a blast on the weekends with my charger.
 

·
Registered
Joined
·
645 Posts
Discussion Starter #4 (Edited)
Awesome. It must be great having it back. Repair looks like it was done well. Does it look as good up close?
It looks good as new to me...they left a little wax residue in the cracks, but I can deal with that. They even went so far as to male sure my Silverstar and LED bulbs made it into the new headlight assemblies.
 

·
Registered
Joined
·
645 Posts
Discussion Starter #7
Looks great but why did you change the logo's up on the hood though I like them.
The one on top is reminiscent of the 1970 Charger Super bee, just made to fit my Charger's shape. And the "HEMI 6.1" is just cool.
 

·
Registered
Joined
·
575 Posts
Looks like Eddie Cordes did a great job!
 
1 - 8 of 8 Posts
Top