Charger Forums banner
1 - 10 of 10 Posts

·
Premium Member
Joined
·
796 Posts
Discussion Starter · #1 ·
First time to the track with the Daytona and the heat and humidity took its tool..... 90+ degrees and LOTS of humidity....

Fastest time of the day 14.63 @ 96.07. 60ft time on that run was 2.166.

I'll be going again but not till the middle of Oct. when its cooler.
 

·
Registered
Joined
·
3,886 Posts
Ya the heat will kill your times. How did you cool your car off? Do you have a $25 cent fan mod?
 

·
Premium Member
Joined
·
796 Posts
Discussion Starter · #3 ·
Don't have the fan mod but I will the next time a go.
I think that would have helped a ton.
 

·
Premium Member
Joined
·
796 Posts
Discussion Starter · #4 ·
Finally went back to the track today and had a pretty good day.
Air temp was in the mid 50's this time and I had the 93 tune in
from the predator and it made a difference.

Ran a 14.011 @ 100.41
60' time was 2.072

I got about 12 runs in today and most of the runs were in the 14.0's with
the exception of a few that had a a little tire spin.
Still trying for that 13 second run but it doesn't look like it will happen this year.
 

·
Registered
Joined
·
416 Posts
Finally went back to the track today and had a pretty good day.
Air temp was in the mid 50's this time and I had the 93 tune in
from the predator and it made a difference.

Ran a 14.011 @ 100.41
60' time was 2.072

I got about 12 runs in today and most of the runs were in the 14.0's with
the exception of a few that had a a little tire spin.
Still trying for that 13 second run but it doesn't look like it will happen this year.
sooo close...

what are your mods? Great 60' time too!
 

·
Registered
Joined
·
1,280 Posts
Finally went back to the track today and had a pretty good day.
Air temp was in the mid 50's this time and I had the 93 tune in
from the predator and it made a difference.

Ran a 14.011 @ 100.41
60' time was 2.072

I got about 12 runs in today and most of the runs were in the 14.0's with
the exception of a few that had a a little tire spin.
Still trying for that 13 second run but it doesn't look like it will happen this year.
What's your engine temp when you stage and is your trunk empty?

I am stock and was running in the low 14's. This week I finally emptied the trunk and the engine temp was 165 when I staged. I got below 14 on all runs except the last when engine temp was 203.
 

·
Premium Member
Joined
·
796 Posts
Discussion Starter · #7 ·
I have a K&N CAI, 180 T-Stat, Daiblo 93CAI tune.
The engine temps on all the runs were around 170-180.
Trunk was empty and the rear tires were down to 26 PSI and
the fronts were up to 44 PSI.
Maybe next year I'll get the 13 second run..... ;)
 

·
Registered
Joined
·
3,886 Posts
14 flat is a little high for you mods. You should be able to get this time down with a little practice. Have you read cherry's sticky on how to drag race the right way?
 

·
Premium Member
Joined
·
796 Posts
Discussion Starter · #9 ·
I have been drag racing for 30+ years and held several track championships.... I think I know how to do it. ;)
I think the car is just alittle slow.
 

·
Premium Member
Joined
·
796 Posts
Discussion Starter · #10 ·
Pics taken by the track photographer..... :lol:

Burnout.....

Leavin the line HARD.....
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top