Charger Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
(2011 dodge charger RT AWD) Please help... The Bluetooth control module in my car has failed (Part# 5064986AK) so I decided to try to re-plug all of the connections going to it. Immediately after plugging it all back in, the car won't start just a click but no start. I just had my starter replaced 3 months ago and I just replaced the starter relay last night but it still won't start. I checked all the connections again to make sure I didn't pull any wires but there's nothing that I can see. I even tried starting the car without the module plugged in but it won't. I disconnected my battery and left it disconnected for 12+ hours in hopes that the car start but no luck :(... I believe it would be something related to this module but IDK what would stop the car from starting.

Also when I disconnected the battery it flickered like 6 times fast because there was too much corrosion on the terminals so I cleaned it all off.

I may just buy a new battery tonight just to eliminate that.

Here are the codes I get when I scan for codes:

B16E7 - license plate lamp one control circuit
Circut short to battery or open.
(My license plate light works fine)

C2129 - Battery Voltage: Circut voltage below threshold.

C2128 - ECU Reset/Recover occurred: No subtype information.
 

·
Registered
Joined
·
824 Posts
(2011 dodge charger RT AWD) Please help... The Bluetooth control module in my car has failed (Part# 5064986AK) so I decided to try to re-plug all of the connections going to it. Immediately after plugging it all back in, the car won't start just a click but no start. I just had my starter replaced 3 months ago and I just replaced the starter relay last night but it still won't start. I checked all the connections again to make sure I didn't pull any wires but there's nothing that I can see. I even tried starting the car without the module plugged in but it won't. I disconnected my battery and left it disconnected for 12+ hours in hopes that the car start but no luck :(... I believe it would be something related to this module but IDK what would stop the car from starting.

Also when I disconnected the battery it flickered like 6 times fast because there was too much corrosion on the terminals so I cleaned it all off.

I may just buy a new battery tonight just to eliminate that.

Here are the codes I get when I scan for codes:

B16E7 - license plate lamp one control circuit
Circut short to battery or open.
(My license plate light works fine)

C2129 - Battery Voltage: Circut voltage below threshold.

C2128 - ECU Reset/Recover occurred: No subtype information.
Did you disconnect the battery before re-seating the connectors? On what exactly did you re-seat the connectors? Bluetooth. BCM, HVAC, etc? Where in the vehicle is the module that you re-seated the connectors?
 
1 - 2 of 2 Posts
Top