Charger Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #1
Has anyone experienced issues with no audio on their 2017? I got my car in November and out-of-the-blue yesterday afternoon my audio stopped working. We drove the car in the morning and an hour later the audio would not produce any sound from any sources (just fuzz in the background at Max volume). We could not hear second party on the phone/blue tooth when connected, no NAV voice, etc. This lasted for several hours. I tired resetting the radio, but no luck. We turned the vehicle on/off several times but still no luck. I called Dodge Customer Service right away and unfortunately I had already tired everything they suggested so they of course suggested taking my car to the dealer. But we all know how that goes... the dealer cannot fix a problem they cannot reproduce. We disconnected the car battery for 30 mins and reconnected and still no audio from any sources. Later on it worked again. This is not normal/right. I know Dodge switched to Panasonic for radios in 2017 models, but regardless of that, my radio should always work. I'm concerned this is going to keep happening going forward.

Has anyone experienced the same issue with audio going out? Not happy about this at all. Thank you.
 

·
Registered
Joined
·
1,631 Posts
I get the left channel go out once in awhile and a restart of the car fixes it. Not much the dealer can do if they can't reproduce it and there isn't a TSB on it. If you complained enough, they would probably remove the radio and re-seat everything and put a fresh coat of diaelectric grease on all the contacts. You've got a warranty if there is a lasting issue.
 

·
Registered
Joined
·
30 Posts
First to start, sorry to hear that about your vehicle. Same thing happened to mine I have a 2017 RT blacktop. Mine didn't happen for several hours.. It would lag as well and my reverse camera froze up on while i was backing up from my driveway, luckily i know my driveway well enough for me to know that's not where i was reversing too lol. It happened again to me like a week after and this time i recorded it happening and let the dealership know about it. They took it in and gave me a brand new radio. I've had the new radio in for about 2weeks now and it's been working fine. Just go with your dealer and let them know and ask for exchanging your radio and they'll order you a new one.


Has anyone experienced issues with no audio on their 2017? I got my car in November and out-of-the-blue yesterday afternoon my audio stopped working. We drove the car in the morning and an hour later the audio would not produce any sound from any sources (just fuzz in the background at Max volume). We could not hear second party on the phone/blue tooth when connected, no NAV voice, etc. This lasted for several hours. I tired resetting the radio, but no luck. We turned the vehicle on/off several times but still no luck. I called Dodge Customer Service right away and unfortunately I had already tired everything they suggested so they of course suggested taking my car to the dealer. But we all know how that goes... the dealer cannot fix a problem they cannot reproduce. We disconnected the car battery for 30 mins and reconnected and still no audio from any sources. Later on it worked again. This is not normal/right. I know Dodge switched to Panasonic for radios in 2017 models, but regardless of that, my radio should always work. I'm concerned this is going to keep happening going forward.

Has anyone experienced the same issue with audio going out? Not happy about this at all. Thank you.
 
  • Like
Reactions: HIOCTANE

·
Registered
Joined
·
136 Posts
Discussion Starter #4
Thanks Gilbert! Ih ave an appointment with the dealer for this coming Monday. Did you request a new radio, or did they just give you one? Also, are you still free of issues?

Thanks!
 

·
Registered
Joined
·
24 Posts
If it dose it again you could try putting it in "ship mode and then taking it out again. It reboots everything even the radio. Key run position, hazards on and hold the up arrow button on left side steering wheel. You will now see "ship mode" in the evic.
Chrysler ships all they're vehicles this way as to not inadvertently run the batteries down during the shipping process.
 

·
Registered
Joined
·
2,611 Posts
Can't get back to Ship Mode once you get 100 miles or so on the car.


Sent from my SM-N920T using Tapatalk
 

·
Registered
Joined
·
2 Posts
Has anyone experienced issues with no audio on their 2017? I got my car in November and out-of-the-blue yesterday afternoon my audio stopped working. We drove the car in the morning and an hour later the audio would not produce any sound from any sources (just fuzz in the background at Max volume). We could not hear second party on the phone/blue tooth when connected, no NAV voice, etc. This lasted for several hours. I tired resetting the radio, but no luck. We turned the vehicle on/off several times but still no luck. I called Dodge Customer Service right away and unfortunately I had already tired everything they suggested so they of course suggested taking my car to the dealer. But we all know how that goes... the dealer cannot fix a problem they cannot reproduce. We disconnected the car battery for 30 mins and reconnected and still no audio from any sources. Later on it worked again. This is not normal/right. I know Dodge switched to Panasonic for radios in 2017 models, but regardless of that, my radio should always work. I'm concerned this is going to keep happening going forward.

Has anyone experienced the same issue with audio going out? Not happy about this at all. Thank you.
I have had the exact same thing happen to the 2018 I just bought
 

·
Registered
Joined
·
2 Posts
I have had the exact same problem with my 2018, apparently there are a lot of issues with this and dealers not wanting to help
 

·
Registered
Joined
·
1,806 Posts
I have had the exact same problem with my 2018, apparently there are a lot of issues with this and dealers not wanting to help
Hi Michellew,
We're sorry to hear that you've experienced this. If you would like any additional assistance while working with your dealer, please send our team a private message and we would be happy to get you connected with a case specialist!
Alex
Dodge Social Care Specialist
 

·
Registered
Joined
·
823 Posts
I have had the exact same problem with my 2018, apparently there are a lot of issues with this and dealers not wanting to help
My 2018 does the exact opposite occasionally. You'll leave the car, and come back later. The radio will be on and playing. No way to shut it off short of reboot by pulling fuse. It will eventually shut off by itself if left long enough - hours.
Generally I listen to SXM. When it does this, it seems to jump to and play an FM station - lowest preset.
Dealer response is "we can't dupe it, so we can't fix it". In fact they didn't believe me until I showed a video on my phone - previously posted here. Another occasion, I drove there with it refusing to shut off. Supertech pulled radio fuse and reset radio. "There.... All fixed".... Until it did it again.
They have no way of reporting this shit back to FCA. Based on my experience with FCA corporate when my car was 130 miles from new, even if there was a way for them to report an issue, FCA would do nothing with the info. Just like the PCM lock on cruise issue. "Can't happen"... Except that they saw it on track testing a few years prior. Read the NHTSA docs on that one.
 

·
Registered
Joined
·
1 Posts
Has anyone experienced issues with no audio on their 2017? I got my car in November and out-of-the-blue yesterday afternoon my audio stopped working. We drove the car in the morning and an hour later the audio would not produce any sound from any sources (just fuzz in the background at Max volume). We could not hear second party on the phone/blue tooth when connected, no NAV voice, etc. This lasted for several hours. I tired resetting the radio, but no luck. We turned the vehicle on/off several times but still no luck. I called Dodge Customer Service right away and unfortunately I had already tired everything they suggested so they of course suggested taking my car to the dealer. But we all know how that goes... the dealer cannot fix a problem they cannot reproduce. We disconnected the car battery for 30 mins and reconnected and still no audio from any sources. Later on it worked again. This is not normal/right. I know Dodge switched to Panasonic for radios in 2017 models, but regardless of that, my radio should always work. I'm concerned this is going to keep happening going forward.

Has anyone experienced the same issue with audio going out? Not happy about this at all. Thank you.
Mine happened when car radio died. It happened twice and I don't know what to do
 
1 - 11 of 11 Posts
Top