Charger Forums banner
1 - 20 of 21 Posts

·
Registered
Joined
·
810 Posts
Discussion Starter · #1 ·
Code light came on a couple days ago ... I brought it to the dealership this morning and they said the code indicated it was the thermostat .. Anyone run into this ? I'm wondering if the thermostat may be defective, but it's been in for a couple months with no problem, or if somehow the computer is picking up on it for some other reason ?

The good news is they ordered new fans for me because one is rattling, and they're going to flush and re-fill the cooling system, AGAIN ... Three weeks after it was done the first time, the coolant has that strong ammonia smell to it again ..

The service manager where I go has been awesome, but I'm wondering if they're going to say anything about my changing the original thermostat ... Anyone have a thought ??

Thanks,

Kenny
 

·
Premium Member
Joined
·
3,557 Posts
Code light came on a couple days ago ... I brought it to the dealership this morning and they said the code indicated it was the thermostat .. Anyone run into this ? I'm wondering if the thermostat may be defective, but it's been in for a couple months with no problem, or if somehow the computer is picking up on it for some other reason ?

The good news is they ordered new fans for me because one is rattling, and they're going to flush and re-fill the cooling system, AGAIN ... Three weeks after it was done the first time, the coolant has that strong ammonia smell to it again ..

The service manager where I go has been awesome, but I'm wondering if they're going to say anything about my changing the original thermostat ... Anyone have a thought ??

Thanks,

Kenny

Yup, I have had the same experience several times with CEL's on the 176, my mom is babysitting my car while im gone (making sure it stays in line :nervous s ) and the CEL came on for the low thermostat and she took it in and they replaced it, not a single word said
 

·
Registered
Joined
·
4,495 Posts
I have read that if the car doesnt reach 180 degree within a certain time period it throws a code. Whats the weather like where you live? Maybe the car isnt warming up as fast.
 

·
Premium Member
Joined
·
3,557 Posts
I have read that if the car doesnt reach 180 degree within a certain time period it throws a code. Whats the weather like where you live? Maybe the car isnt warming up as fast.
The reason you gave for the CEL coming on is correct :), just depends on how fast she warms up
 

·
Registered
Joined
·
13,502 Posts
The good news is they ordered new fans for me because one is rattling ...
Can I ask you to give more info about this rattle ?

I think one of my fans may be rattling too, but I can't pin-point the noise because it comes and goes, it's a short-lasting rattle / crackle from the front of the engine area and it doesn't matter whether it's cold or hot it does it intermittently ...

Is this what you're experiencing ?

Thanks.
 

·
Registered
Joined
·
377 Posts
I have the same issue as GPWEBMAN...anyone know what it is?
 

·
Registered
Joined
·
731 Posts
I'm running the 183 thermostat in mine and no codes yet.

When it throws the code does it stay on just until the car warms up or does it stay on forever until you get it checked out by Dodge?
 

·
Registered
Joined
·
810 Posts
Discussion Starter · #8 ·
I have read that if the car doesnt reach 180 degree within a certain time period it throws a code. Whats the weather like where you live? Maybe the car isnt warming up as fast.
The weather HAS turn colder, so I guess that's it ... I really like the 176 but I'm sure they'll throw a 193 back in ... This sucks if it keeps happening ... It doesn't go out when the engine warms up either ...
 

·
Registered
Joined
·
810 Posts
Discussion Starter · #9 ·
Can I ask you to give more info about this rattle ?

I think one of my fans may be rattling too, but I can't pin-point the noise because it comes and goes, it's a short-lasting rattle / crackle from the front of the engine area and it doesn't matter whether it's cold or hot it does it intermittently ...

Is this what you're experiencing ?

Thanks.
Yes, that's basically it ... It sounds like the fan hitting the shroud or something, with a little rattle thrown in .. I really noticed it using the .50 fan mod at the track .. They are replacing both fans as soon as they come in ...
 

·
Premium Member
Joined
·
3,557 Posts
the code will eventually go away on its own if HAL detects 3 or more (im not sure about that number though) warmups where she gets to temp fast enough

btw stock thermo is 203*, not 193* ;)
 

·
Registered
Joined
·
810 Posts
Discussion Starter · #11 ·
the code will eventually go away on its own if HAL detects 3 or more (im not sure about that number though) warmups where she gets to temp fast enough

btw stock thermo is 203*, not 193* ;)
I knew it ended in a 3 !! :silenced: .... Guess I'll have to forget about babying her when she's cold, but it was a nice idea ... Sorry next door neighbors !!
 

·
Registered
Joined
·
498 Posts
Er, which code?
I ask because I keep getting 0128 (on my Daytona) even though I have the stock thermostat and I *think* it's just not warming up quickly.
 

·
Registered
Joined
·
739 Posts
Is anyone throwing a code with the 183 degree thermostat from Autozone?
Just installed mine, but did a long test drive....no codes whatsoever with the 4128. And, with the fan temps adjusted, it's a rock at 185 solid.
 

·
Registered
Joined
·
810 Posts
Discussion Starter · #16 ·
I can't seem to get it warm quickly enough times to shut the stupid light off ... I'm sure they are going to throw the 203 in which is fine since it's getting cold here... I'll just put the 176 or 183 back in, in the Spring .. She'll be going into hibernation soon anyhow...
 

·
Registered
Joined
·
731 Posts
I can't seem to get it warm quickly enough times to shut the stupid light off ... I'm sure they are going to throw the 203 in which is fine since it's getting cold here... I'll just put the 176 or 183 back in, in the Spring .. She'll be going into hibernation soon anyhow...
Ya I am in Iowa and running the 183 thermostat. I will go ahead and throw the stock one back in it for winter. I am putting it away in by storgae bay but will get it out on very nice sunny days during the winter to air tires and have some quick fun.
 

·
Registered
Joined
·
160 Posts
Hi,
running the 176 tstat and just got the check engine light last night. it just turned cold here in ny and I'm sure it's that the engine isn't warming up quickly enough. I'm not even going to bother trying to get the car to warm up quickly enough 3 times because it's so cold out here that my car runs very steadily at around 176. I doubt that's going to be hot enough to turn off the cel. The only problem is that I have an 08 and the key diagnostic doesn't seem to be working. this thing doesnt even use a real key. I'll let you guys know what the code is if I can find out.
 

·
Registered
Joined
·
731 Posts
You guys with the 176 thermostats, may want to just swap it to the 183. I don't think any of us are throwing codes with the 183....Knock on wood!
 

·
Registered
Joined
·
160 Posts
just figured out how to do the key diagnostic with my 08 and it was the thermostat code.
 
1 - 20 of 21 Posts
Top