Charger Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
Hello,

Could anyone steer me in the right direction in regards to troubleshooting my AC system.

I have no cool/cold air coming from my AC no matter what setting its set on. The heat works just fine and the blower works well too.

I've checked the fuses in the trunk to make sure they were all were in place which they were. I checked fuse 14 aswell to make sure it hadn't blown too. The manual doesn't tell me much more about which fuses work with the AC.

I have the dual climate control AC system
 

·
Registered
Joined
·
626 Posts
Hello,

Could anyone steer me in the right direction in regards to troubleshooting my AC system.

I have no cool/cold air coming from my AC no matter what setting its set on. The heat works just fine and the blower works well too.

I've checked the fuses in the trunk to make sure they were all were in place which they were. I checked fuse 14 aswell to make sure it hadn't blown too. The manual doesn't tell me much more about which fuses work with the AC.

I have the dual climate control AC system
Is the A/C clutch clicking on and off? If so how often? The refrigerant charge may be low, and require a recharge with dye so it can be inspected for leaks with a black light.
 

·
Registered
Joined
·
3,599 Posts
I had this exact same problem with my 2006 late last summer. I took it to the dealer, they said it just needed recharged, then called me back later in the day and said they recharged it with dye, and it was running all over the place...the condenser unit was shot. Their price was pretty high (don't remember exactly), but I had a local shop fix it instead of them...ended up paying the local shop about $580 for the repairs plus a second recharge...that's the bad thing about A/C Problems, a lot of them can't be diagnosed without paying for a recharge, then once it's fixed you have to have it recharged again.
 
1 - 3 of 3 Posts
Top