Charger Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
467 Posts
Discussion Starter #1
Yesterday, I stopped by my uncle's store since I had a few minutes to spare to show him my new AFE II CAI. My uncle is a huge car nut, former indy car driver, and has a tuned/turbo miata at home (300 rwhp).
So he's looking at the whole setup and he noticed that the bottom edge of the afe shielding is scratching the inner fender's paint (near the overflow bottle). Since the shielding only bolts in place in one place, the whole thing has some play in it. He recommended splitting a piece of fuel line and covering the bottom edge with it.
Have you guys noticed this issue with your car and the AFE CAI (or other CAI)? What have you done to take care of this issue?

My uncle also said since the CAI was bolted only in one place, that it would eventually break off and recommended that I bolt on some kind of bracket elsewhere. Opinions?

Then he says since you got all this air going in, you need to do something about the exhaust. Well, I'll get to that eventually. Maybe we could use his miata's garage lift to install catbacks or something. Also, suggested getting some colored/silicone hoses and stuff to dress up the engine. Finally, he said that he could make some engine cover stickers for me inside his jewelry shop.
 

·
Registered
Joined
·
507 Posts
mine rubs too. . but if you wanted you can prolly buy a piece of rubber (similar to the piece that goes on top) and put it on the bottom. .
 

·
Registered
Joined
·
3,886 Posts
I think that is a common problem, I've read post about ppl complaining about that. I never bothered to look if it is happening to my car.
 

·
Premium Member
Joined
·
28,730 Posts
the airaid cai fits like it came with the car...attaches to the bottom part of the stock air box itself. thats why i didnt buy the afe one. just my 2cents:knockout:
 

·
Registered
Joined
·
342 Posts
I'm probably going to install mine this weekend, I'll see what this issue is all about :)
 

·
Registered
Joined
·
660 Posts
I don't have the inner fender problem but my AFE rubs the hood a bit. Every one I've seen does this. No big deal. The AFE has been proven to make more power than all others except the Hammer. That's a good trade off for a little scratched paint that you can't even see. The AFE is a solid install. I would just leave it alone.
 

·
Registered
Joined
·
174 Posts
I was worried the bottom might vibrate so i took some of the old breather hose 3" and split it, slid it on the bottom and never looked back
now im glad i did dont want paint rub to turn into rust.
 

·
Registered
Joined
·
467 Posts
Discussion Starter #8
thanks for the responses. i called aFe yesterday and they will be sending me an extra trim seal (hood seal) to put along the bottom edge. also sending an extra grommet since mine got a little stretched during installation.

by the way the aFE tech rep said that the stage 2 CAI is not designed for '07 R/Ts. yet the vendor i bought from marked as 05-07 chargers/magnums/300s. she was going to talk to the engineers. should work-its the same engine setup. at most they could make some improvements over the previous kits.
 

·
Registered
Joined
·
1,440 Posts
Actually......Mine came w/a wee sticky backed foam hosing for just that purpose.
 

·
Registered
Joined
·
14,728 Posts
they all rub, mine does and everyone i've put on does. I cut about 1/2 inch from the bottom piece so it doesnt contact drivers fender well anymore. They also rub on the hood a bit. I adjust bump stops up on the hoods 1 full turn and these two methods have helped out a lot.
Not doing the cutting i have and have seen paint worn through on fenders and terrible clacking noise when hitting bumps. If you dont have the stuff to cutt it a piece of foam tape or weatherstrip like the top part of the box has will help
 

·
Registered
Joined
·
342 Posts
thanks for the responses. i called aFe yesterday and they will be sending me an extra trim seal (hood seal) to put along the bottom edge. also sending an extra grommet since mine got a little stretched during installation.

by the way the aFE tech rep said that the stage 2 CAI is not designed for '07 R/Ts. yet the vendor i bought from marked as 05-07 chargers/magnums/300s. she was going to talk to the engineers. should work-its the same engine setup. at most they could make some improvements over the previous kits.
Installed mine today and use a piece of the 5/8 hose to create a trim for the bottom where it touches the car. It also came with the trim seal for the hood.

I have an 07 R/T and the vendor said it would fit :confused: I wonder what the difference is ..

PS- I like the new sound:grin:
 

·
Registered
Joined
·
467 Posts
Discussion Starter #12
ok fixed up my cai and fender on saturday afternoon, since i received the extra trim seal from aFe.
I started to disassemble the filter and begin using my touchup paint to fix the 2 areas that were scratched on the fender. As I was doing so, I noticed on the back side of the shielding that there is a hook/flap. Then I saw on the side of the coolant overflow bottle that there is a channel for the 'hook/flap' to slide into. Well, guess what I didnt have it slid in there. it appears that there would be no more problem. So I finished touching up the paint, installed the seal along the bottom edges, and reinstalled the filter.
case closed.
 
1 - 12 of 12 Posts
Top