Charger Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I have a 2015 Dodge Charger SRT 392 with the active dampening system. I went to the drag strip yesterday after picking up some new Forgestar D5's and 28 inch Mickey Thompson ET Street R's and ran a couple times. Car performed amazingly and was cutting low 1.6 60 foots all day in bad DA leaving off idle. However, on my way home, about 15 minutes after leaving the track, I got hit with a "Service Active Dampening Suspension" message and locked me into sport mode and haven't been able to figure out what happened or what broke or why. Does anybody know what might have happened or why it might have broke and what i can do to fix it before having to take it to the dealership?
 

·
Premium Member
Joined
·
2,754 Posts
Disconnect the battery in the trunk for 15 minutes. (Negative terminal). Weird things happen to the electronics every time I hit the dyno or track for some reason. Resetting the electronics seem to fix my gremlins
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
Disconnect the battery in the trunk for 15 minutes. (Negative terminal). Weird things happen to the electronics every time I hit the dyno or track for some reason. Resetting the electronics seem to fix my gremlins
I tried pulling the negative terminal last night for about 5-7 minutes and it still hit me with the service message. I'll go try it again right now and leave it disconnected for longer.
 

·
Premium Member
Joined
·
2,754 Posts
If you do not have a tuner, take it to an auto parts store that has one and see if the code will clear after disconnecting the battery.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #5
If you do not have a tuner, take it to an auto parts store that has one and see if the code will clear after disconnecting the battery.
Using the Car's internal code readers it doesn't have nay codes nor is a check engine light on. When I turn the car on it gives me a "Service Active Dampening System" message and when I go to the SRT pages, my suspension is locked in sport mode.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Check the wires and harness at each shock in case a wire got damaged when doing the wheels swaps.



Sent from my SM-N960U using Tapatalk
Just took a quick look through the gaps in the wheels and can see a wire that was worn through on both rear sides I guess from the smaller wheels and big tires. Looks like I will be taking the car to the dealership some time this week to get it fixed.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8 (Edited)
291589
291590

Anybody know what these two wires happen to be? These are the two wires that were worn through by my drag radials and I believe they might be the cause of my suspension issue.
 

·
Registered
Joined
·
1,734 Posts
I have a 2015 Dodge Charger SRT 392 with the active dampening system. I went to the drag strip yesterday after picking up some new Forgestar D5's and 28 inch Mickey Thompson ET Street R's and ran a couple times. Car performed amazingly and was cutting low 1.6 60 foots all day in bad DA leaving off idle. However, on my way home, about 15 minutes after leaving the track, I got hit with a "Service Active Dampening Suspension" message and locked me into sport mode and haven't been able to figure out what happened or what broke or why. Does anybody know what might have happened or why it might have broke and what i can do to fix it before having to take it to the dealership?
Hi Josh, Glad to hear you are working with your dealer for this concern. If you are in need of additional support while in service, please let us know. We can certainly have a case escalated for additional assistance while in service.
Rob
DodgeCares
 
1 - 9 of 9 Posts
Top