Charger Forums banner

1 - 20 of 35 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Okie doke, well i have an 07 charger with about 45k on it. My husbadn was installing a new stereo this weekend, and when he finished, then suddenly the AC wont turn on at all! Hazards, radio, etc work all except the ac...

Took it to the dealer and they said the Diode for it was missing and wanted to charger me almost $300 for parts/labor.

Question is, my husband could easily figure out how to fix it, he works on cars all the time, but i need to know where to get one, (how much the part is) and general info about this thing?

Id rather not spend $300 to have it fixed when i can have it fixed for free or for just the cost of the part...

Thanks ahead of time!
 

·
Registered
Joined
·
5,193 Posts
Sweetie they are B.S ing you up one side and down the other.
EITHER your husband left the ac control panel unpluged and they are trying to rip you a new one-or-that ac control panel is damaged [defective]
They go bad alot. new ac control panel cost $160.
FYI there isnt any diode exposed any were around the area your husband was working on the radio.
DIODE'S are only used in electronic modcules and they are mounted to computer boards and sealed IN A CASE CALLED THE MODCULE
IN a nut shell-they are lying to you. tell your husband to go back in and check to see if the ac control panel is pluged in correctly.
if so then the ac control panel may be bad and he can switch that him self.
 

·
Registered
Joined
·
5,193 Posts
I cant believe there are scum bags like this at dealerships and repair shop still lying to customers.
DONT fall for the [you need a new muffler bearing trick]
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
everything is plugged in correctly, and when we figured out ac wasnt working, we took the new stereo out and plugged stock stereo back in. i knew the stereo had nothign to do with it, but i only mentioned it cause it was fine before we took the control panel off to put the new stereo in and when we put it back together now the ac doesnt work. so if everything is plugged in correctly (it is) what im gathering is that i need to go buy a new panel? thats fine, im just confused a bit. happen to have any diagrams laying around?
 

·
Registered
Joined
·
5,193 Posts
SOME TIME WHEN YOU ON PLUG THEM you can damage the pins on the ac control panel and inturn they lose connection inside the panel. the male pins become loose at the mother board inside the ac control
AS LONG AS THE AC FUSE IS STILL GOOD then its the ac panel that got damaged when he unpluged the harness from the back side of the panel.
LOT of times its a little ruff tryin to unplug it and thats when it gets damaged
MAYBE [wickedcharger] will chime in with the diagram
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
ok good. so just to be clear when i head over to pick up the car in about an hour (so i can yell at them and feel better for them trying to sham me) theres no way the so called "diode" could be missing? theyre saying like what i said, its something thats completely missing and that it isnt covered by warranty since its missing, not defective....
 

·
Registered
Joined
·
298 Posts
Diode would be soldered to the board behind all that plastic housing. It seems like a pin is out of whack or the control panel is indeed broken if nothing is unplugged. As for the dealer, how do they know an aftermarket radio was installed if you removed it before the trip over there?
 

·
Registered
Joined
·
5,193 Posts
CORRECT! they are trying to play you.
there are NO exposed diodes in the car to come loose/get damaged or to become missing.
I'd go talk with the general manger about them trying to take avantage of you. AND ask him to use his computer to show him this thread only after they give you a repair order [paper] stating it is a missing diode.
ask the service manager to explain were in the wire harness for the radio and or the ac is there a diode behind the ac control that could be missing.
AND inform them that you talked to a ASE and MECP CERTIFIED electronics tech on CHARGER FORUMS
 

·
Registered
Joined
·
5,193 Posts
Diode would be soldered to the board behind all that plastic housing. It seems like a pin is out of whack or the control panel is indeed broken if nothing is unplugged. As for the dealer, how do they know an aftermarket radio was installed if you removed it before the trip over there?
correct-and in this case even if a diode for the mini lights in the ac control panel was knocked loose by droping it-they should replace it under warrenty and send her on her way a happy customer.
the panel costs them $100 and is a 5 minute replacement then they ticket chrysler for the part and labor
 

·
Registered
Joined
·
14,728 Posts
as sound said there is no diode and i think in 11 years of working on cars i've replaced one diode for failure, however i think there is some info missing.

a/c doesnt work means nothing

does the fan work and blow on all settings
does the eatc/mtc/temp control unit light up when you turn on the lights
does the a/c compressor kick on yes or no
does the air blow but not cold


If your husband was "able to diag this himself" why did he not do so prior to you wasting your money to pay for the dealer to diag it

the a/c system is complex and isnt gonna be able to be diaged by anyone here with just
"not working" as the symptom
 

·
Registered
Joined
·
5,193 Posts
A DIODE is nothing but a gate to block either a postive or a negative from traveling back down a electrical path for every one reading this
IT will only let current [or a ground path] flow in one direction
 

·
Registered
Joined
·
14,728 Posts
and to add to that, it doesnt "go out" like a fuse or something. It is not a amperage limiting device its nothing but a one way check valve for electron flow
 

·
Registered
Joined
·
9 Posts
Discussion Starter #15 (Edited)
Ok everybody: UPDATE:


(pardon the rant:)

THOSE LOW LIFE STUPID mf'S!!!!! Control Panel Was fine. What happened was when it went out, i took it to the dealer i bought it from. They couldnt fix it because they were a chevy/hyundai dealer and told me to take it to dodgeland of columbia (SC).... While i was at the chevy/hyundai dealer, they checked all the fuses and said they were fine/all there/etc....

Yesterday i went with hubby to them, got the paperwork saying the fuses were ok/all there/etc and then went to dodgeland. Had them show me where it was "missing from", how it would have "fallen out" (it didnt) and why the heck would it take $300 to fix?!?

Turns out, its NOT a diode missing (OBVIOUSLY) its one of the fuses in the power control box. It however WAS missing.

BUT theres NO WAY IN HECK it would fall out. I had 3 mechanics look at it and tell me it HAD TO BE PULLED! So.... What im guessing is that i blew the fuse originally when it stopped working, and when i took it to original dealer they just didnt either check that one or missed it and it was bad. Because i know for a fact all those fuses were there. Both my husband and myself checked them all before we went to the shop, and yet it suddenly comes up missing at the dodge dealer where they know they wont make any money off my warranty??

Heres what i think happened:

They found the bad fuse and simply pulled it and threw it away knowig (a) warranty doesnt cover missing parts (b) im a female and they didnt think i would ask questions (c) that they would make over 12X the money spent to fix it because they were going to charge me an hour and a half labor +parts + diagnostic fee for something that all you had to do was open my trunk and plug the thing in for a total of $276.99

Needless to say, that didnt fly. I paid the diagnostic fee, an additional $22.50 for the part, and sat right there in their bay and plugged it in to make sure it worked before i left, and voila! it did! for a total of $112.05

Sorry this is so long but heres my warning if your ever in Columbia SC...NEVER EVER EVER go to this dealer unless you wanna get screwed prison style!:slap:



THANK YOU EVERYONE!!!!
 

·
Registered
Joined
·
9 Posts
Discussion Starter #16 (Edited)
a/c doesnt work means nothing

does the fan work and blow on all settings
does the eatc/mtc/temp control unit light up when you turn on the lights
does the a/c compressor kick on yes or no
does the air blow but not cold


If your husband was "able to diag this himself" why did he not do so prior to you wasting your money to pay for the dealer to diag it


then suddenly the AC WONT TURN ON AT ALL! Hazards, radio, etc work all except the ac...


Thanks ahead of time!



he did tell me it was a fuse, but we couldnt figure it out because that happens to be the ONE fuse we didnt check





WOW-no thank you?
as i said, thanks ahead of time, but again in the previous post, i appreciate you all so thank you!
 

·
Registered
Joined
·
5,193 Posts
FUSE's just dont blow. YOUR husband must have made the mistake of unpluging or pluging in the ac control panel with the key on .
Easy TO DO SINCE YOU HAVE TO HAVE THE SHIFTER pulled back out of park with the key turned so you can get the panel off for the radio.
GOOD FOR YOU for standing up to them although $112 IS a lot of money for a fuse. BUT thats water under the bridge now.

NEXT time you have a problem you know were we are at!!

OH and welcome to the forums!!!!
IF some of us seem like jack holes-thats because we are!! hehe
YOU'LL learn to love us.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #18
lol sound, you are right, absolutely right actually, he did leave the keys in even after i told him ot take them out. he did pull it out of park cause he couldnt get the panel off without it...Then again hes the type of person who you cant tell him he is wrong if he thinks he did everything perfectly, which he did except he forgot about the keys....

and as for being a holes, lol, believe me yall are cake compared to some people ive dealt with. Did i mention that im in the army, and on top of that i work in a psychiatric ward??:biggrinjester:
 

·
Registered
Joined
·
201 Posts
Army!, Psychiatric Ward!...now I'm impressed!
Hey I live in Summerville, SC so thanks for the heads up on the bogus dealer. I'll make sure to try and avoid them.
Glad you have your ride back on line and maybe I'll cya at the next M&G some time soon.
 
1 - 20 of 35 Posts
Top