Charger Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hello everyone I started my car today and the uconnect screen didn’t turn on just stays black. I just got this car a couple weeks ago and it’s already having issues so took to the dealership and they told there backed up and won’t be able to check it out for a month. I’ve tried disconnecting the battery to maybe reset it but no luck. Just wondering if anyone else has had this problem and if so is there an easy solution I’m not trying to wait a month to have full access to my brand new car....
 

·
Registered
Joined
·
328 Posts
I have seen issues where the Uconnect locks up or has some other issue. Usually turning off the car and opening the door causes the unit to turn off and reset. I believe there is even a self checking feature where the unit will reboot itself if it freezes or becomes unresponsive to input. I have had my touchscreen freeze and about 10 seconds later, the unit reboots and works as normal.
So your saying even the back up camera doesn't work?

As far as the long lead time to get an appointment, go to another dealership.I have 2 local dealers. When one said 3 weeks before they could see my brand new car, I called the other and got an appointment for the following Monday. If that isn't an option for you, call the service manager and politely plead your case.
There is a way to do a hard reset on the you connect. Maybe somebody will chime in on the procedure since I don't know what it is
 

·
Registered
Joined
·
1,918 Posts
The fuse locations/assignments may have changed from MY-to-MY but there should be a couple of mini fuses in the trunk fuse box you can check (15A radio screen, 15A radio).
.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
  1. I have seen issues where the Uconnect locks up or has some other issue. Usually turning off the car and opening the door causes the unit to turn off and reset. I believe there is even a self checking feature where the unit will reboot itself if it freezes or becomes unresponsive to input. I have had my touchscreen freeze and about 10 seconds later, the unit reboots and works as normal.
    So your saying even the back up camera doesn't work?

    As far as the long lead time to get an appointment, go to another dealership.I have 2 local dealers. When one said 3 weeks before they could see my brand new car, I called the other and got an appointment for the following Monday. If that isn't an option for you, call the service manager and politely plead your case.
    There is a way to do a hard reset on the you connect. Maybe somebody will chime in on the procedure since I don't know what it is
    Yea even the back up camera isn’t working. I did find a different dealership that was able to look at today. Hopefully they can resolve the problem quickly
 
1 - 4 of 4 Posts
Top