Charger Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I noticed a rattle coming from the engine compartment. I heard it first at a drive through with the sound rebounding from the wall. I was thinking it may be a PCV valve, but the car only has 38000 miles on it. It sounds like a plasticky grinding kind of noise. I took a video of it hoping someone can help a brother out...
Engine Sound
 

·
Registered
Joined
·
114 Posts
I noticed a rattle coming from the engine compartment. I heard it first at a drive through with the sound rebounding from the wall. I was thinking it may be a PCV valve, but the car only has 38000 miles on it. It sounds like a plasticky grinding kind of noise. I took a video of it hoping someone can help a brother out...
Engine Sound
All I can hear is your exhaust pull the belt and see if the noise persists


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
1,052 Posts
My money is on the water pump. It sounds like several we have had here as of late on their way out. Thankfully, your PT warranty will cover it. For giggles, remove the serp belt, and check the WP pulley for wiggle/wobble. I bet the noise goes away if you were to run it for a moment with the belt removed.

Don
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4
My money is on the water pump. It sounds like several we have had here as of late on their way out. Thankfully, your PT warranty will cover it. For giggles, remove the serp belt, and check the WP pulley for wiggle/wobble. I bet the noise goes away if you were to run it for a moment with the belt removed.

Don
I'll give that a check, thanks for the advice. Is this an imminent failure type thing?
 

·
Premium Member
Joined
·
1,052 Posts
Might fail tomorrow, and might run another 100K, although not likely. Better to get it done asap.

Don
 

·
Registered
Joined
·
7 Posts
Discussion Starter #6
Looks like you guys were right. Water pump has some looseness even with the belt on I can rattle it. Now to make an appointment...:rolleyes:
 

·
Premium Member
Joined
·
1,052 Posts
OG:
IMO, certainly not, especially at 38K. You may recall the WP issue with the '15 Hemis was bad enough that the oem pumps were on national backorder. Dealers went to the extreme in some cases of installing aftermarket or oem 6.4L pumps on 5.7s to get customer's cars out of the bays, and back on the road. Hopefully they learned a lesson (yeah, right!) about accepting the lowest bid when sourcing parts.........

Don
 

·
Registered
Joined
·
94 Posts
Add me to the failure list for WP on a 17 SP. Occurred couple mos. back at about 30K miles. Unusual noises (rattles) heard on start-up in garage.

Getting to be too many warranty issues w/this car: (1) transmission oil leaks = new trans pan & gasket.(2) Multiple issues with Uconnect 8.4 NAv = eventual replacement of the "black box' (two months wait for the new unit) = continued Uconn 8.4NAv problems where screen goes black = another 2 days with dealer's senior tech = found "Code1488" = problem (screen going black) reoccurring at least 10 times since the 'repair'; reboots with power off-on action. Another dealer visit when i get time. (3) Random COLLISION WARNING alerts when there is NO car ahead of me = another day with dealer 'senior tech' who 'tuned it' = at least it seems that problem has been corrected. (4) latest: One FOB quit working Oct 31 = new FOB replaced under warranty.
 

·
Registered
Joined
·
1,704 Posts
Add me to the failure list for WP on a 17 SP. Occurred couple mos. back at about 30K miles. Unusual noises (rattles) heard on start-up in garage.

Getting to be too many warranty issues w/this car: (1) transmission oil leaks = new trans pan & gasket.(2) Multiple issues with Uconnect 8.4 NAv = eventual replacement of the "black box' (two months wait for the new unit) = continued Uconn 8.4NAv problems where screen goes black = another 2 days with dealer's senior tech = found "Code1488" = problem (screen going black) reoccurring at least 10 times since the 'repair'; reboots with power off-on action. Another dealer visit when i get time. (3) Random COLLISION WARNING alerts when there is NO car ahead of me = another day with dealer 'senior tech' who 'tuned it' = at least it seems that problem has been corrected. (4) latest: One FOB quit working Oct 31 = new FOB replaced under warranty.
Hi Heckcat,
We sincerely regret to hear of the trouble that has been associated with your ownership experience. Please know that our team would be more than happy to provide an additional layer of assistance if you do end up connecting with your dealer. What we can do is escalate a case on your behalf so that one of our Case Specialists could work alongside your dealer to find a potential solution to any current concerns you’re experiencing. Feel free to follow up with us via private message if this would be of interest.
Rob
DodgeCares
 
1 - 12 of 12 Posts
Top