Charger Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
Hi all,

I'm new to the community as I just purchased a '13 Charger in August. After making my first payment just TWO DAYS AGO I noticed several of the leds on the bottom strip of the trunk lid are failing. It seems to be on the bottom left and right corners of the trunk lid that one or two of the leds are out completely and the ones around it are flickering. The only thing I could think possibly causing this that I have done to the car is an led license plate light I installed instead of the stock garbage. (I plan on removing it tonight to see if it makes any difference.) If anyone could help me with resolving this I would be very appreciative, dealer wants $500+ to replace the whole bar on the trunk lid:mad: :mad: . For a car thats maybe 3 years old that seems extremely unreasonable as LEDs should be lasting 10+ years....
 

·
Registered
Joined
·
324 Posts
Is it not under warranty? Are the LEDs out in a group, or are they scattered? Usually grouped LEDs is a sign of failure at the connection somewhere... but highly likely not something you can repair yourself since you have to take it all apart. Might have to deal or pay the price...
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #3 ·
Is it not under warranty? Are the LEDs out in a group, or are they scattered? Usually grouped LEDs is a sign of failure at the connection somewhere... but highly likely not something you can repair yourself since you have to take it all apart. Might have to deal or pay the price...
It's at 39k right now so I'm just out of the warranty window for electrical, even though I bought it certified. They are out in groups but in two seperate areas on the bottom of the trunk lid. Both areas surronding the brake lights and the brake lights themselves are fine. I'll put up pics tonight when I take out the tag light.
 
1 - 3 of 3 Posts
Top