Charger Forums banner

1 - 20 of 39 Posts

·
Registered
Joined
·
89 Posts
Discussion Starter · #1 ·
For the life of me, I cannot get my 2013 Charger SRT to kick into launch mode. I have hit the ESC button twice on the center console, only to have it turn off ESP and turn it back on. Am I missing something? Hitting the wrong button? Was there a system update that I missed?
 

·
Registered
Joined
·
263 Posts
Same here man. Mind doesn't have it ether. I think they didn't put it on the first 2013 srt's. Wonder if there is a add on to the 2013's that dont have it.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #3 ·
I have heard that there is a update that needs to be done in order to enable it, but that was only with the '13 Challies... I haven't seen anything on the '13 Chargers..

Any idea on how to pull up the version ID of your car? I guess I need to make a trip to the dealership... Ugh..
 

·
Registered
Joined
·
330 Posts
When you say "launch mode" are you referring to turning the esp completely off? I am assuming that the new SRT's still function like my 07, meaning one press of the button turns it partially off, while holding the button for 10 seconds or so while still in PARK will bring up the dings and turn the esp system off. Things could have changed, but that's how the older ones work. There's also the old trick of while at a stop or gently rolling, turn your key as if starting the car. The radio, warning lights and all will cut off momentarily (starter won't engage) and then you are in full off mode. Again, this works on the earlier models, can't guaranty it on yours. Maybe someone else has tried it on the newer ones and will speak up.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #6 ·
Here's what it is:

"A new for 2013, standard launch control system helps maximize straight-line acceleration.

When the vehicle is at a complete stop, the driver engages the system by pressing the ESC button twice and then with their foot securely on the brake, quickly applies full throttle. Launch control holds the engine at optimal launch rpm (1,825) and waits for the driver to release the brake. Launch control then uses engine torque management to achieve controlled wheelslip for maximum acceleration up to 62 mph (100 kph). "

According to SRT, it should display it up on the dash, letting you know that it is indeed engaged.. Though i have hit that button till i got "Pac-Man" thumb, and it still isnt working.
 

·
Registered
Joined
·
26 Posts
Here's what it is:

"A new for 2013, standard launch control system helps maximize straight-line acceleration.

When the vehicle is at a complete stop, the driver engages the system by pressing the ESC button twice and then with their foot securely on the brake, quickly applies full throttle. Launch control holds the engine at optimal launch rpm (1,825) and waits for the driver to release the brake. Launch control then uses engine torque management to achieve controlled wheelslip for maximum acceleration up to 62 mph (100 kph). "

According to SRT, it should display it up on the dash, letting you know that it is indeed engaged.. Though i have hit that button till i got "Pac-Man" thumb, and it still isnt working.

There's also a Yellow sheet that comes with your manual. It explains exactly how to engage the Launch Control, and that it is not available for the first 500 miles of the vehicles life.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #8 ·
Waaay past the 500+ mile point, unfortunately. I will double check the manual on that "Yellow Sheet". Maybe the dealership skimped on mine...
 

·
Registered
Joined
·
441 Posts
Vehicles built prior to 12/2012 are not equipped with this feature. Engineering is currently working on a fix for this concern.
 

·
Registered
Joined
·
89 Posts
Discussion Starter · #11 ·
Yup, actually called the techs out at SRT and found out the same answer. They actually had to open up a formal complaint on my behalf for the issue. So, for all of you who are without the feature, make sure you hit them up and provide them with your VIN info and dealer location. Once they have a solution, we should get a fix. 855-SRT-TEAM

Till then I guess its "partial" mode.. :locked:
 

·
Registered
Joined
·
19 Posts
Thanks for the phone number. This is a known problem and they stated that "a number of chargers manufactured prior to December 2012 escaped the plant without the correct programing."

Since this is a standard feature on the SRT, there is not a sales code that can be programed and they are currently trying to solve the problem (read, they don't know how to fix it yet) In the mean time they are compiling a list of customers that have this problem so they can be contacted once a solution is found.

So it appears that they do not know what cars did or did not get the programming and from reading some of the posts here and elsewhere, if your production date is prior to December your Charger may or may not have gotten the launch control programming.

So, if you cant get your car into launch control mode, call the number listed above and get your name on the list!
 

·
Premium Member
Joined
·
898 Posts
The scheduled release for the launch control Flash update is April 5th (2013 model year, SRT only, Challenger/300/Charger).
 

·
Registered
Joined
·
831 Posts
The scheduled release for the launch control Flash update is April 5th (2013 model year, SRT only, Challenger/300/Charger).
Any updates? People have been trying to go to their dealership for the flash with no luck.
 

·
Registered
Joined
·
3 Posts
Mine was built in August and it definitely doesn't have launch control. I went outside this evening to see if I could activate it and just got "ESC off" then back on when I pressed it twice. Hopefully the flash is coming soon. I've been able to run a 4.8s 0-60 without LC so I'm interested to see how much this will help.
 
1 - 20 of 39 Posts
Top