Charger Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
I have a clunk coming from the drivers side front end when I go over mild bumps. A trip to the dealer found the problem to be a bad strut. The dealer is going to replace both of the front struts and its still under warranty so no money issues. I was told the struts are back ordered and it has been 2 weeks already. I did some searching on some of the mopar parts sites just to see what is available out there and none of the ones I found had them in stock. A couple of them even show them as being discontinued, kinda strange for a relatively new vehicle.

I was wondering if anyone else has had this problem or might know something about it?

Thanx
 

·
Registered
Joined
·
1,836 Posts
I have a clunk coming from the drivers side front end when I go over mild bumps. A trip to the dealer found the problem to be a bad strut. The dealer is going to replace both of the front struts and its still under warranty so no money issues. I was told the struts are back ordered and it has been 2 weeks already. I did some searching on some of the mopar parts sites just to see what is available out there and none of the ones I found had them in stock. A couple of them even show them as being discontinued, kinda strange for a relatively new vehicle.

I was wondering if anyone else has had this problem or might know something about it?

Thanx
Starion,

I'd like to see what I can do to assist you. Please PM me your VIN, contact information, and dealership you've been working with.
 
1 - 2 of 2 Posts
Top