Charger Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hello guys, I'm new to the forums and just got my first Charger. Absolutely love it! However there's a couple things I'm still trying to nip in the butt.

So at all times my Traction (skid light) control is off, ESP/BAS light is on (meaning it's deactivated) as well as my ABS light is on. While operating the vehicle 100% of the time all safety assists are turned off. However, simply trying to reactivate these systems doesn't work, and it's automatically turning itself off every time I start the vehicle, as if it's permanent.

I wouldn't be surprised if this is a solenoid or sensor malfunction from previous abuse or something, I just need to know where I start looking for troubleshooting.

2010 R/T 5.7l w/ 109,000 miles.
Any help is very much appreciated thank you!

 

·
Registered
Joined
·
1,352 Posts
Its most likly a wheel abs sensor, a quick scan with a scanner will determin which one and you can replace it.
A bad one will cause exactly what your describing.
You can try the key dance, on/off on/off on and see if it displays the P code and if so look it up and it will tell you which one is having issue
 

·
Registered
Joined
·
136 Posts
Key dance won't give the body codes need a scanner capable of pulling them either dealer or a good reader

Sent from my E6910 using Tapatalk
 

·
Premium Member
Joined
·
1,107 Posts
CC:
Your Charger is a beautiful example of the last year of the Gen 1 Chargers! X 2 on the issue being wheel sensor related. Thankfully, they are not pricey, and can be DIY for those so inclined.

Don
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Its most likly a wheel abs sensor, a quick scan with a scanner will determin which one and you can replace it.
A bad one will cause exactly what your describing.
You can try the key dance, on/off on/off on and see if it displays the P code and if so look it up and it will tell you which one is having issue
I have a scanner at work, but I'm unsure if it's a good enough one to pull the ABS light code, I think it only pulls up DTC's. If not, it's only $151.42 for all four new sensors to be replaced.

CC:
Your Charger is a beautiful example of the last year of the Gen 1 Chargers! X 2 on the issue being wheel sensor related. Thankfully, they are not pricey, and can be DIY for those so inclined.

Don
Thank you very much! The 1st Gen is one of my favorites. I'm most impressed with the handling, being as heavy as it is. Thank you as well for the feedback on wheel sensors. I will probably replace them all brand new, unless I can pull the code and see specifically which one needs replaced. That's the best case scenario.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Pulled codes at advanced auto parts.

LF Speed Sensor Fault.
Purchased Mopar replacement part, installed on driver side. Drove it for one cycle and all lights on dash finally went off on next startup. Also my ESP button is functional now. Thank you all for your help.
 

·
Registered
Joined
·
4,419 Posts
CC:
Your Charger is a beautiful example of the last year of the Gen 1 Chargers! X 2 on the issue being wheel sensor related. Thankfully, they are not pricey, and can be DIY for those so inclined.

Don
Those 3rd Gen wheels look great on your car !!! (I have them on my wife's 2016 Rallye)
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
Those 3rd Gen wheels look great on your car !!! (I have them on my wife's 2016 Rallye)
Thanks my man! These are on my wife’s car too haha. Once it’s payed off, I’ll have to get her another one so I can make a nice project out of this one. Financial mistakes are okay if you get more smiles per gallon.
 
1 - 9 of 9 Posts
Top