Charger Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hmmmm. . .

Please bare with me, I'm a newbie. . .

I have a 2007 Charger R/T, HEMI MDS. There's a nasty smell coming out of the A/C unit particularly on hot or humid days.

I have an 06 Jeep Grand Cherokee which had the same problem. I checked with Jeep / Chrysler and found the TSB for the jeep. Unfortunately, my 5 star jeep dealership told me it wasn't covered because my vehicle was out of factory warranty. I have the extended 8/80 warranty but he said that didn't matter. That's another issue for the jeep forum I guess. . .

I'm searching for something similar for the charger. Has anyone seen a TSB related to this? I so far have been unlucky in locating TSB's on this site. Maybe a little more due dilligence on my part will pay off tonight?

I also have a section of my rear windshield defroster not working right behind the drivers seat. It's really annoying. Anyone hear anything about that?

Then there's the transmissions "valve body connector" which I was told had come loose. I was told that was why when I returned home to my garaged charger, there was about two quarts of trannie fluid on the floor. He said he tightened it up and added some fluid. Now begs the question. . . What about trannie service? This car has a MBZ trannie with a sealed dipstick. I have no way of knowing when it's low on juice. Am I to believe I really don't have to do anything to this trannie but for every 100K miles? What if there's a leak I don't know about that causes me to fry the trannie? Especially after the warranty runs out???

I finally dropped the charger off at the dealership with 3000 miles on it. The service manager told me that the problem with the A/C unit was that the sealant used to install the unit often causes this smell. He told me that he would check it out and clean the evap coil and spray some deoderizer in there. I, not being armed with a TSB, was unable to suggest anything other than what had happened in my jeep. . .

He said that if the problem persisted, I should get a can of LYSOL and run the A/C full blast then spray it into the air intake(s). This is some real crap. LYSOL for a smell that is supposed to be caused by sealant. Sounds to me that this guy knows theres microbial growth on the evaporator and doesn't want to follow proper protocol. Too much work for him I guess? He figures he'll have me use lysol to kill some bacteria in the vents and duct work as a continual temp fix until the warranty runs out. . .

I guess this all boils down to TSB's while my car is still under warranty. I found out that the dealerships (even 5 star) WILL NOT DO TSB WORK ONCE THE VEHICLE IS OUT OF WARRANTY. EVEN IF IT HAS THE EXTENDED 8/80 WARRANTY. . . That is unless you want to fork out the cold hard cash for the repairs/mods. . .

Any suggestions. . .
 

·
Registered
Joined
·
10,665 Posts

·
Registered
Joined
·
1,879 Posts
from Northern Illinois!
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top