Charger Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
185 Posts
Discussion Starter · #1 ·
Hello,

This is the first car I have ever had and I do not know if this is approaching her ending. I bought my Charger slightly used from a dealership late in 2008 with 14,000 miles. Over the 7+ years I have had the O2 defect replaced, jerry-rigged the transmission to overcome the stuck in park defect (still works fine btw) and now the transmission is starting to go (I believe).

I drive my car daily, very briefly but daily and on Sunday the problems began. I drove about 15 minutes on the parkway on a warm Sunday for New Jersey. About 4 hours later after a round of golf I am driving home and while exiting the parkway (after another 15 minute drive home) my car is not shifting out of 3rd or 4th gear. I stop at a stop light and begin accelerating and my car is not shifting into the next gear. I know exactly how my car drives and shifts and realize immediately that it is not shifting gears so I use the slap-stick to the left and then to the right with no response. I slow down to another light and my rpm's begin lowering (as opposed to the gears shifting down) while my exhaust starts making that noise that manuals cars make when rpm's rev down. I come to a stop and as I accelerate the car moves from 1st to 2nd, then into 3rd gear but as I accelerate and decrease speed (while doing roughly 35 mph) the tranny never shifts into 4th or 2nd gear.

I immediately brought the car to a trusted mechanic friend who ran a deep scan on the entire vehicle which he said covers the transmission computer and electronics in the transmission. He found nothing. He checked the tranny fluid, which I regrettably did not change at 60,000 miles and said it was full but medium dark and odorous.

There is a service bulletin out for this transmission for a reprogram and it is done by the dealer. He found this service bulletin by Googling my VIN number. But my friend said that this type of reprogram does not address the up-shift problem. He is going to change my tranny fluid and filter, then I am going to the dealer for a reprogramming on the tranny.

Just curious if anyone on here has ever had this reprogramming done on their Charger and if so what was the outcome? If I need a new transmission I might have to walk away from her because who knows what else could go as this 8 year old Dodge approaches 100,000 miles?

The service bulletin that I am referencing can be found here: Description: CHRYSLER/DODGE/JEEP: FLASH:DIAGNOSTIC TROUBLE CODE, DTC P0740 OR P1798 AND AUTOMATIC TRANSMISSION SHIFT IMPROVEMENTS 1-2 OR 2-3 COLD SHIFT IMPROVEMENTS. *PE

Want to learn how to fix NHTSA #10026168 ?

Website that I am referencing:
http://www.dodgeproblems.com/tsbs/Charger/2007/

Please help guys!
 

·
Registered
Joined
·
874 Posts
First off, it's just barely broken in good dude. Not nearing it's end of life. These cars will easily do 250k on the motors and transmissions.

And not getting over 35mph while slowing down will not usually mean a trans will upshift to higher gear when it is considering downshifting as you slow.

I don't think that is your problem myself. It sounds more like it is going into "limp mode".

Sometimes stopping and turning it off and restarting it will temporarily clear it, sometimes not.

There are some good transmission guys on here, but my guess is it is the electrical connector board right inside the trans oil pan. It is a known problem and is pretty easy/cheap to fix even if you can't do the work yourself.

If you're dong the oil and filter it is about ten more screws to replace it also. Plenty of folks do this themselves, but it isn't all that expensive if you go indy for the work.

Griz

Read these:

http://www.chargerforums.com/forums/showthread.php?t=136281&highlight=connector+board


http://www.chargerforums.com/forums/showthread.php?t=159596&highlight=connector+board
 
1 - 2 of 2 Posts
Top