Charger Forums banner

1 - 16 of 16 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter · #1 ·
Hello hope everyone is having a great holiday and new year. I have an 07 charger with 170k on the body and 10k on the motor. Now when I am going and it the breaks the car steering wheel shakes and makes a knocking noise in front of the car. When I go over a hilly parking lot the knocking noise happens too. What could this be?


Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
11,698 Posts
170k, most get fixed long before that. Common known issue, lower suspension, get it fixed before it breaks and causes an accident
 

·
Registered
Joined
·
400 Posts
it could be a couple of things, inner or out tie rods, the strut is bottoming out, lower ball joint i think.
 

·
Registered
Joined
·
400 Posts
When I push up and down on the car it makes creaking noise.

google a spring and strut shop near you and see if the front end diagnostic check is about 30 to 35 bucks and if so pay them and find out everything that you need replaced and only replace what's broke, don't do both sides, unless you want to do preventive maintenance which is good if you have the money for it. and sometimes it pays off to do extra work while the car is apart, you'll save on labor that way.
 

·
Registered
Joined
·
400 Posts
it can also be the steering column coupling. if you have symptoms of bad tie rods after replacing them it's the steering coulumn lower coupling u joint.
 

·
Registered
Joined
·
1,298 Posts
Good luck...I have replaced tie rods, sway bar links and bushings, upper joints, strut mounts, steering rack...still knocking and getting worse...going back in the shop in a week or so

-- sent from my HTC DNA --
 

·
Registered
Joined
·
851 Posts
Good luck...I have replaced tie rods, sway bar links and bushings, upper joints, strut mounts, steering rack...still knocking and getting worse...going back in the shop in a week or so

-- sent from my HTC DNA --
Did you tighten the cross brace?


Sent from AutoGuide.com Free App
 

·
Premium Member
Joined
·
11,698 Posts
it's your shocks. Granted i'm at 120k but i just replaced literally all of my ball joints, tie rods etc and i still have it. Shop says it's the shocks.
There's a reinforcement that some people have had the bolts come loose on. Two near the computer mounted on the firewall, two in the same place on drivers side. At one time we had pictures, but the OP deleted the pics :( Bolts (nuts?) are vertical, and IRC 13mm.
 

·
Registered
Joined
·
851 Posts
There's a reinforcement that some people have had the bolts come loose on. Two near the computer mounted on the firewall, two in the same place on drivers side. At one time we had pictures, but the OP deleted the pics :( Bolts (nuts?) are vertical, and IRC 13mm.
I believe you are referring to the cross brace which i already checked.


Sent from AutoGuide.com Free App
 

·
Registered
Joined
·
400 Posts
I dont have any tie rod issues/symptoms. Just still have a slight knocking sound from needing shocks.
if the shocks, struts, are bad because they have a knocking sound over bumps it's because your bumpstopper is finished. your strut is bottoming out and the bump stopper isn't stopping it from bottoming out. you can either replace the bump stopper or strut and bump stopper. if you aren't doing the repair yourself then replacing the strut with the bump stopper is more ideal.

Good luck...I have replaced tie rods, sway bar links and bushings, upper joints, strut mounts, steering rack...still knocking and getting worse...going back in the shop in a week or so

-- sent from my HTC DNA --
you need to find someone who can diagnose front end suspension parts for 30 to 40 bucks and replace only if it's broken; 1 control arm instead of 2, 1 of the 4 tie rods.
 

·
Registered
Joined
·
1,298 Posts
Yup....working on it....

-- sent from my HTC DNA --
 

·
Registered
Joined
·
129 Posts
i agree with eggsnbacon

i had a front end noise that for life of me, i could not find out what it was
new struts,tie rods (inner and outer) lower and upper control arms,stabilizer links,tension strut brace. this "rattling" was still there.

finally found out that the passenger strut mount (new might i add) wasn't good.
the strut had the slightest play in it and on certain roads it would rattle. not really a safety issue i think, more of just a annoying sound. the strut was under warranty but not the labor obviously.

oh well . .
 
1 - 16 of 16 Posts
Top