Charger Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
He are a few problems. many of which were discussed in previous posts but still not to many collective answers were figured.

1. The paint on the plastic bodyside moulding is almost off. It sorta turned into a dingy yellow plastic looking thing. It is a go-mango car. Is this covered under warrenty?

2. The car randomly doesnt start. Battery totally dead. I have had the battery replaced under warrenty and the charging system is always ok, but it is still dying after it has been sitting for a day or 2. Dealer even was able to replicate the problem but did not find anything wrong. They just replaced the battery and said it was ok. This started around the same time the remote start was installed but that was checked and they said that was ok too. I heard something about the ECM possibly being bad. Could it be that?

3. Brakes... If I go slowly around a slight curve with the steering wheel turned and the brakes a little on there is a loud squeeling noise that sorta sounds like tires squeeling. I have no clue what it could be. The car was aligned at a dealer and it has new tires and new front brakes and it still does it. It has to be going around a curve with the brakes on for it to happen. It doesnt happen any other time.

I hope you can help me for items 2 and 3. Because no dealer wants to try.
I am trying to get everything figured out before i take it one last time to get things fixed under warrenty.
 

·
Registered
Joined
·
352 Posts
He are a few problems. many of which were discussed in previous posts but still not to many collective answers were figured.

1. The paint on the plastic bodyside moulding is almost off. It sorta turned into a dingy yellow plastic looking thing. It is a go-mango car. Is this covered under warrenty?

2. The car randomly doesnt start. Battery totally dead. I have had the battery replaced under warrenty and the charging system is always ok, but it is still dying after it has been sitting for a day or 2. Dealer even was able to replicate the problem but did not find anything wrong. They just replaced the battery and said it was ok. This started around the same time the remote start was installed but that was checked and they said that was ok too. I heard something about the ECM possibly being bad. Could it be that?

3. Brakes... If I go slowly around a slight curve with the steering wheel turned and the brakes a little on there is a loud squeeling noise that sorta sounds like tires squeeling. I have no clue what it could be. The car was aligned at a dealer and it has new tires and new front brakes and it still does it. It has to be going around a curve with the brakes on for it to happen. It doesnt happen any other time.

I hope you can help me for items 2 and 3. Because no dealer wants to try.
I am trying to get everything figured out before i take it one last time to get things fixed under warrenty.

1. I would think the dealer would replace that for you unless the car was in Hurricane Katrina.

2. Depending on who installed the remote start, could be directly responsible for the intermittent non-starting. If you have a chip modification on the ECM, it would, and could interfere.

3. I get the same noise and I had my calipers replaced, rotors turned and no more noise. My car has 30K on it, and I drive hard, so you come to expect these things. When my warranty is up, I will purchase an extended one,cause there is only one way to drive these cars!

4. Undo the remote start first, and I think you will notice the problem gone, unless you really need it (living in the frozen tundra), I would never get one!
Too much energy consumption and too many things to go wrong....and
I would get a second opinion about the front end sound. Although your dealer sells Dodge, doesn't mean they are good at diagnostics and repair.

Good luck!
 
1 - 2 of 2 Posts
Top