Charger Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I've seen a few other posts on here about the same thing but figured I would post my own to get some opinions. About a month or two ago I noticed my Charger felt different when driving it. I'm not quite sure how to explain it but I will try my best. It seems to have trouble when I accelerate, like it doesn't want to speed up. It sorta lurches forward then goes, but still seems like its having trouble. When I take my foot off the gas, it again lurches and slows down (more than normal). When I'm stopped it makes a sort of rumbling noise and shakes a little bit and stops when I take my foot off. The check engine light has not come on. I would like to figure it out before it gets any worse. If you need more info I can give it to you.
Thanks in advance!
 

·
Vendor
Joined
·
10,364 Posts
I've seen a few other posts on here about the same thing but figured I would post my own to get some opinions. About a month or two ago I noticed my Charger felt different when driving it. I'm not quite sure how to explain it but I will try my best. It seems to have trouble when I accelerate, like it doesn't want to speed up. It sorta lurches forward then goes, but still seems like its having trouble. When I take my foot off the gas, it again lurches and slows down (more than normal). When I'm stopped it makes a sort of rumbling noise and shakes a little bit and stops when I take my foot off. The check engine light has not come on. I would like to figure it out before it gets any worse. If you need more info I can give it to you.
Thanks in advance!
Sounds like some carbon is deposited in the engine...upper cylinder and maybe in the injectors. The detergents in the fuels do not get this clean and some gasolines actually make it worse.......techron is an example where it has polyether amine that will clean a little bit and then combine with copper and vanadium and put gum back on parts post combustion.

Off the shelf additives do nothing for this besides carbon up your engine oil quicker.

May be a good idea to get some ACES IV-FIC that will clean it up really well...pumps, injectors and valves/pistons.

Very aggressive and yet very safe. Smooth running occurs after continual use. :beerchug:

Here also is something we wrote about injectors:

http://www.chargerforums.com/forums/showthread.php?t=224185

Regards,
Brian
BND Automotive LLC:driving:
440-821-9040
www.bndautomotive.com
 

·
Registered
Joined
·
111 Posts
When is the last time you changed the plugs? I was having a similar issue and had lost a ground off one of my plugs. Problem was fixed after the plug change
 

·
Registered
Joined
·
1,637 Posts
Have you had the gas tank replaced yet? Your is part of the problem group and the problem you are having is similar to it.
 
1 - 4 of 4 Posts
Top