Charger Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello,

My gf has a 2006 charger RT with the hemi engine. It has been giving her problems for a couple weeks now. Sometimes when you are just idling either at a traffic light or when you first start the car it starts shaking a bit and the check engine light flashes on and off. From my experience it feels like a misfire. I pulled the code before and it was a random misfire and I believe it had a certain cylinder misfire code. I can pull them again tomorrow and get the exact codes. When you start moving this goes away and it runs fine. As soon as you start moving the check engine light goes solid. Sometimes this problem doesnt even happen for days and the check engine even completely shuts off.

You guys have any suggestions, Im pretty good with cars but don't know anything about hemi's. I changed the oil yesterday because it was well past due. I was thinking plugs next, because they are also due. Aside from that I don't really want to throw money at it without knowing what the problem might be.

Thanks for your help,
Kevin
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Thank you, that was a good real. I did infact check that out before I posted. It just seems much more of a harsh problem then I have. This has never stalled or acted up in any way other then misfiring at idle on occasion. For a 45$ish part It might be worth a try. Definitely would have been one of the last things I would have thought of.

Kevin
 

·
Premium Member
Joined
·
17,450 Posts
Front of the engine next to the water pump on the passenger side. Easy to get to and easy to change.
 

·
Registered
Joined
·
587 Posts
Plugs, coil packs, or faulty valve seat. I would investigate in that order.
 
1 - 8 of 8 Posts
Top