Charger Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone. I'm trying to help a friend out here. It's an 06' charger 5.7 hemi. There is alot of valve train noise coming from it, like alot of rocker arms and lifters clattering. It only has 50,000 miles on it, and someone said it might be the oil pump. Has anyone else had or heard of any problems like this?
And where in the engine is the oil pump? I'm a chevy guy, I don't know much about mopar.
Thanks for the help.
 

·
Premium Member
Joined
·
17,450 Posts
I seriously doubt it's the oil pump. No issues there.

It may simply be the "Hemi Tick" that these cars have inherent to the design. Some non-Mopar folks think it sounds like valves that need adjustment or oil starvation. It isn't and it's perfectly normal.

Another possibility is that you have a valve seat coming undone. It's generally rare, but the early 5.7L engines are known to drop valve seats. If you have one coming loose, it will rattle like hell and clatter a lot. If it is a valve seat coming loose, it will be isolated to only one side of the engine. It also won't persist for long before it actually drops and kills the engine. I doubt that's what you are experiencing unless the noise just started happening suddenly.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Yes the noise was just all of a sudden. And it's not a little tick but a big bunch of ticks, lol. Sounds like a diesel, lol.
 

·
Premium Member
Joined
·
17,450 Posts
That's a problem. You need to have it checked out immediately by a qualified shop before you wind up buying a new engine.
 

·
Registered
Joined
·
2 Posts
I Have my 06 Charger in the shop right now. Bad oil pump. Milling puts out a performance oil pump part #10342. If you watch your oil pressure you can tell. My oil pressure is fine till I lay into it and then the oil pressure drops to zero, shut the car off restart and oil pressure is fine till I crank the rpm's to it again. While your there you might as well do the T-stat, water pump and anything that's on the front of the engine. The oil pump is on the front of the engine ran off the crank behind the water pump. I'll let you know within a few days how it works out for I am picking it up tonight after work.
 

·
Registered
Joined
·
1,925 Posts
I Have my 06 Charger in the shop right now. Bad oil pump. Milling puts out a performance oil pump part #10342. If you watch your oil pressure you can tell. My oil pressure is fine till I lay into it and then the oil pressure drops to zero, shut the car off restart and oil pressure is fine till I crank the rpm's to it again. While your there you might as well do the T-stat, water pump and anything that's on the front of the engine. The oil pump is on the front of the engine ran off the crank behind the water pump. I'll let you know within a few days how it works out for I am picking it up tonight after work.
I'd stick with the stock pump or the 6.1 pump. We have seen a lot of failures with the Melling pump.
 
1 - 7 of 7 Posts
Top