Charger Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
So, quick highlights of the problem:

Randomly the car will start with an active misfire
  • Symptom 1: Car is loud at idle
  • Symptom 2: Car shakes whenever breaks applied, wheel turned, or is driven
  • Symptom 3: Check engine light will flash repeatedly
If I drive the car for any length of time in this state the car will throw the engine light on permanently and enter limp mode.

No DTC's are present when read on a scanner, the light is just on for 'apparently no reason'. My guess is it's a misfire count that throws the light.

Now if I shut the car completely down (key to off), and restart, the problem disappears.

I've done a massive amount of internet mechanicing, read a ton of horror stories of similar issues (though theirs aren't intermittent like mine), and the only thing I can come up with is a TCM fault which isn't registered correctly with the PCM which ends up causing the start sequence to fail.

However, I'm not completely convinced that's the problem - and no one has been able to point me in a better direction yet (my standard mechanic and the stealership). So, here I am reaching out to one of the strongest Charger communities to see if you have any pearls of wisdom which may help me past this.

The only other evidence I have that the TCM is faulty is the car doesn't seem to shift correctly. I can redline the engine with only 1/4 throttle going from first to second to third. Downshifting seems a bit bumpy as well sometimes.

The car:

2006 Charger SXT w/135k miles - no mods, daily driver.
Bought used last August at 116k miles.
Had the car brought up to date with maintenance when purchased (full tuneup, trans flushed, etc.).
Added a two-way alarm/remote start the same month I bought the car.
This problem started a month ago, is completely random, and only occurs at start up (via remote start or physical key turn).

I thank you all in advance for any help and/or advice you can give.
 

·
Premium Member
Joined
·
15,199 Posts
what sort of scanner are you using?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I'm not sure what type the mechanic used, and the Dealership was just an inquiry, so they didn't hook it up to anything (there were no dash lights on when I went to see them). I've also done the key dance which showed nothing either.
 

·
Premium Member
Joined
·
15,199 Posts
Had the car brought up to date with maintenance when purchased (full tuneup, trans flushed, etc.).
Added a two-way alarm/remote start the same month I bought the car.
This problem started a month ago, is completely random, and only occurs at start up (via remote start or physical key turn).

I thank you all in advance for any help and/or advice you can give.
Dont suppose you know what sort of flush was done? If not, you might ask the place that did it what machine they use.

Who did the install? These networked machines can be finicky about electronics....
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Specifically, no. Golling Chrysler / Jeep / Dodge did all service on the car (so one of the largest dealerships in my area). The only thing I know about it is it's the flush recommended by Chrysler at the 120k mark.

The alarm was done by Cartunes. I had it installed within the first few days of owning the car, so she's been on a Starscan several times since, as well as had a full $120 used car inspection done by Golling. If that were a (the) problem, shouldn't it have showed sooner?
 

·
Registered
Joined
·
5,091 Posts
My buddy's 06 sxt is doing something similar, upon warmup, the engine will just rev, he has to turn it off, let it sit then turn it on again.
he was showing no codes with the key dance but i plugged in the diablosport and it showed PCM issue see below, p0700
TCM Issue see below
P2784-input speed sensor 1/2 correlation
P0731-Incorrect gear ratio 1

Also at 128k miles... maybe they are the same?
just happened to him yesterday
i will keep updated on the problem if i can
maybe u can wave down a decked out charger owner and see if they have a diablosport they can read your engine light with? Lol
 
1 - 6 of 6 Posts
Top