Charger Forums banner
cooling
1-5 of 5 Results
  1. Charger Problems/Assistance
    2014 Charger Pursuit 5.7 with dual fans. They turn on manually from my Tazer, but won't activate when the car gets hot. Temps get above 210 and the fans don't kick on. They don't turn on with the AC either. All fuses and relays are good. What could be the problem?
  2. Charger Problems/Assistance
    Hi guys and gals. I bought an 09 Charger with the police package with the 5.7 Hemi at the beginning of this year, and it has been great..... until about a month ago. I replaced my water pump and thermostat, due to my water pump developing a leak about a month ago. It has been perfectly fine...
  3. Charger Problems/Assistance (2011 +)
    2011 SE I have no climate controls. Have searched on here and see common issue where people can't control heat/cool, but that's not my issue. Issue started after I was having trouble with my 4.3 Uconnect system. The screen was black, but climate control dials/buttons worked fine...I just...
  4. Charger SRT-8 Discussion
    So I just changed my coolant and noticed that my fans are only on if the air is on, or if the air is off..then they don't turn on unless the temp gets right on 230 then it cools down. is this normal? on the highway the temp is at 180, in traffic it jumps to 230 and the fans are on.
  5. Charger Problems/Assistance
    Iv been losing fluid looks like around the passenger side where this small hose on the top of the radiator connects on my 2010 charger 3.5. It's def just TF but can't seem to pinpoint where it's coming from. The upper small hose on the radiator passenger side connects to what looks like the...
1-5 of 5 Results
Top