Got my 2017 Hellcat, but have a little problem. - Dodge Charger Forums
Charger SRT Hellcat Supercharged 6.2L Discussion Would you like the BLACK KEY or the RED KEY?

Reply
 
Thread Tools Search this Thread Display Modes
post #1 of 29 Old 08-02-2017 Thread Starter
Hreagle
Junior Member
 
Join Date: Jun 2012
Location: Rochester, N.Y.
Posts: 12
(Thread Starter)
Got my 2017 Hellcat, but have a little problem.

I got my 2017 Charger SRT Hellcat and it came with one glitch. On a random basis, almost always on the first start-up in the morning, my display screen freezes up. This often happens on the backup camera screen and it's a freeze frame. This screen stays on frozen even if I shut the car off and open the door to kill power. My radio goes off, and after a mile or so of driving, it reboots showing the splash screen and then all is well. Has anyone else had this issue, and if so was it fixed? This is getting annoying and my dealer says the factory is aware of it and is working on a software upgrade to resolve it. I'm curious if anyone else got one of these. Thanks!
Eagle
Hreagle is offline  
Sponsored Links
Advertisement
 
post #2 of 29 Old 08-02-2017
YardleyBill
Senior Member
 
YardleyBill's Avatar
 
Join Date: Apr 2017
Posts: 266
Curious to hear the answer because my 2017 SP does the same thing.

Yesterday it stayed frozen on a SXM channel. The song was playing, but nothing related to the radio would work. Touchscreen, dials, mute button, nothing.

2017 Black Scat Pack
YardleyBill is offline  
post #3 of 29 Old 08-02-2017
radak04
Member
 
Join Date: Jul 2017
Posts: 66
It's almost certainly software. My '15 Durango had some weird software issues with the uConnect. Rebooted a couple times while I was driving around. Lost all the favourite radio stations a few times. It hasn't had any bugs since the last software update.

The HellCat must use a different version of the software. I'm surprised it's still buggy.
radak04 is offline  
Sponsored Links
Advertisement
 
post #4 of 29 Old 08-02-2017
Stevens12
Senior Member
 
Stevens12's Avatar
 
Join Date: Mar 2012
Location: Altoona, Pa
Posts: 4,215
So this is a legitimate issue. I thought the post was gonna be something like, my car keeps melting the tires, how do you stop from doing that.. .haha

Well thats that the dealership is for. But as mentioned, software glitch and or radio and should be easily addressed.

Current 2013 Dodge Charger SRT8, Corsa Extreme exhaust, 20% window tint, AEM drop in filter, Custom Wrap
Current 2015 Dodge Charger SXT AWD, Hellcat spoiler
Stevens12 is offline  
post #5 of 29 Old 08-02-2017
AZ_Scat
Junior Member
 
Join Date: Jul 2017
Posts: 13
I have had the same thing happen on my 2017 SP, although it only happens once every 2-3 weeks instead of everyday. I would have to guess that it is a software issue that is correctable with a patch, so I don't think we are stuck with it permanently. It is definitely annoying, but I think we just have to live with it for the moment. Sorry that I can't be of any more help!
AZ_Scat is offline  
post #6 of 29 Old 08-03-2017
vivid
Senior Member
 
Join Date: Feb 2017
Posts: 148
Count me in on this I've got a 17 SP same thing.. happened twice now that I've noticed atleast



Sent from my SM-G930W8 using Tapatalk
vivid is offline  
post #7 of 29 Old 08-03-2017
isaacmaple08
Senior Member
 
isaacmaple08's Avatar
 
Join Date: Apr 2015
Posts: 274
Garage
Several members on the Hellcat forums experiencing the same thing, Uconnect released an update but it looks like it was "unstable" bricking people's Radio so they pulled it.

http://www.hellcat.org/threads/2017-...lx-cars.86977/

2015 Charger SRT 392 - LMI CAI, BT Catch Can, 180 Tstat, Diablo-Modified PCM, Custom Dyno Tune - SOLD

2016 Charger Hellcat - LMI CAI, Speedlogix Catch Can, Mopar 3.09 LSD, ID 1050x, GripTec 2.75", ATI 10% Balancer, Killer Chiller, SW Long Tubes, DSS Aluminum DS, Brisk Spark Plugs, 21v BAP, 93/e85 Griff Tuned

2014 Grand Cherokee SRT - LMI CAI, SW Long Tubes, DS Catch Can, 180 T-Stat, 93 GriffTuned
isaacmaple08 is offline  
post #8 of 29 Old 08-07-2017 Thread Starter
Hreagle
Junior Member
 
Join Date: Jun 2012
Location: Rochester, N.Y.
Posts: 12
(Thread Starter)
At least it isn't just me!

I was hoping this wasn't just a problem with my car, I always seem to get the weird ones. It's been hot here for a while and the issue has not happened in a few days. I can just about count on it happening if it's cold and wet, but not much so on hot mornings. Maybe the weather is just a coincidence, but it does seem to be a factor. I'll keep bugging my Dodge store and hopefully the update will be along soon. Thanks for the replies...

Eagle
Hreagle is offline  
post #9 of 29 Old 08-07-2017
YardleyBill
Senior Member
 
YardleyBill's Avatar
 
Join Date: Apr 2017
Posts: 266
For me it seems to be the opposite, when it is hot.

Because the screen is even hot to touch.
YardleyBill is offline  
post #10 of 29 Old 08-07-2017
RitzRT
Senior Member
 
RitzRT's Avatar
 
Join Date: Feb 2007
Location: Northern VA
Posts: 4,368
Quote:
Originally Posted by Hreagle View Post
I was hoping this wasn't just a problem with my car, I always seem to get the weird ones. It's been hot here for a while and the issue has not happened in a few days. I can just about count on it happening if it's cold and wet, but not much so on hot mornings. Maybe the weather is just a coincidence, but it does seem to be a factor. I'll keep bugging my Dodge store and hopefully the update will be along soon. Thanks for the replies...

Eagle
All these discussions around flaky uconnect. Mine went bonkers just once so far. It got into a state where it was stuck on the radio input and seemed to be wedged. It ignored input from physical buttons and didn't respond to any touches to the screen. I was on a short run to the store and when I came out to drive home and call my local dealer, it was behaving normally again. That was about a month ago and hasn't happened since.

Best,

Granite 2017 Charger R/T Scat Pack
Formerly had Cool Vanilla 2006 Charger R/T
RitzRT is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Charger Forums > Dodge Charger SRT-8 > Charger SRT Hellcat Supercharged 6.2L Discussion

Related Threads
Thread Thread Starter Forum Replies Last Post
2017 Charger Daytona 392 mopar intake combined with hellcat tube...results blinelaxd27 Performance Discussion/Modifications 12 08-07-2017 07:19 PM
Mystery of Hellcat Oil Volume 2015/2016 vs 2017 370 HEMI BND Automotive 27 06-16-2017 03:29 PM
AWD Hellcat Challenger for 2017? frank1966 Off-Topic 39 12-07-2016 12:59 PM
2017 Charger Hellcat Slidd Charger SRT Hellcat Supercharged 6.2L Discussion 20 09-29-2016 08:20 AM
Hellcat-Powered Jeep Grand Cherokee Here By End Of 2017 RScottyL Off-Topic 5 01-17-2016 11:00 AM


Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Dodge Charger Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










User Tag List

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode


Forum Jump

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome