How to turn off check engine light in 3.5L? - Dodge Charger Forums
Are you interested in the Dodge Challenger? Visit the Challenger Forum @ ChallengerTalk.com for your Dodge Challenger information!
Dodge Charger Forum Header Dodge Charger Header Right
 

Go Back   Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Charger Problems/Assistance You having problems with your Charger? Check and see if it is a common problem and get answers here.

Reply
 
Thread Tools Search this Thread
Display Modes
Old 01-30-2008, 02:23 PM   #1
raystash
Member
 
raystash's Avatar
 
Join Date: Jul 2007
Location: Vancouver
Posts: 38
How to turn off check engine light in 3.5L?

Hey everyone,

I was stuck in snow & I had to rev up quite a bit trying 2 get out. Then my check engine light comes on??? I'm sure it's nothing but I want that off. Anyone know how to turn it off?

Any help will be much appreciated. Thanks in advance.
__________________
Black '06 Charger. Keeping it clean. Debadged. 50% tint all around & 22" AR Torq Thrust M's.
raystash is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-30-2008, 02:45 PM   #2
alocharlie_golf
Junior Member
 
Join Date: Jan 2008
Location: central Louisiana
Posts: 2
Try disconnecting the battery ground (negative post) for 60 seconds. that should clear the default codes.

____________________________
'06 SXT; Black; leather; R/T 18s; Airaid CAI; Magnaflow dual catback; DC strutbar; Superchip II
alocharlie_golf is offline   Reply With Quote Quick reply to this message
Old 01-30-2008, 03:09 PM   #3
raystash
Member
 
raystash's Avatar
 
Join Date: Jul 2007
Location: Vancouver
Posts: 38
thanks...i'll give this a try now.
__________________
Black '06 Charger. Keeping it clean. Debadged. 50% tint all around & 22" AR Torq Thrust M's.
raystash is offline   Reply With Quote Quick reply to this message
Old 01-30-2008, 03:11 PM   #4
jarpod
Senior Member
 
jarpod's Avatar
 
Join Date: Sep 2006
Location: YOU SEE??? IM NOT A BANNED USER
Posts: 1,606
Send a message via Yahoo to jarpod
geez that is the worst advice ever!
disconnecting and reconnecting the bat is just plain dumb since there are active circuits and computers active that might get damaged if you do that.
Take it to the dealer and see what the code is! you might have a serious issue and your charger is just telling you that it needs to be checked!
the battery thing might work, but you are better off going to a dealer
__________________
Waiting for:
2009 Jeep Liberty limited custom built with every single factory option there is.

All Gone
2006 Silver R/T with factory Uconnect and sunroof
jarpod is offline   Reply With Quote Quick reply to this message
Old 01-30-2008, 03:40 PM   #5
Ksleigh
Senior Member
 
Ksleigh's Avatar
 
Join Date: Apr 2007
Location: BKLYN
Posts: 860
Quote:
Originally Posted by jarpod View Post
geez that is the worst advice ever!
disconnecting and reconnecting the bat is just plain dumb since there are active circuits and computers active that might get damaged if you do that.
Take it to the dealer and see what the code is! you might have a serious issue and your charger is just telling you that it needs to be checked!
the battery thing might work, but you are better off going to a dealer

You won't cause any damage to your car by disconnecting the battery. I would do the key jiggle and get the CEL code your self. If its a serious code than take to the dealer, if not than try reseting w/ the battery disconnected
Ksleigh is offline   Reply With Quote Quick reply to this message
Old 01-30-2008, 04:24 PM   #6
raystash
Member
 
raystash's Avatar
 
Join Date: Jul 2007
Location: Vancouver
Posts: 38
thanks 4 the advice guys. i'm due for a check up so i'll be going in 2 the dealer soon anyhow. that light is annoying though & it only went off after i had 2 rev up quite a bit 2 get outta the snow so i turned it off.
__________________
Black '06 Charger. Keeping it clean. Debadged. 50% tint all around & 22" AR Torq Thrust M's.
raystash is offline   Reply With Quote Quick reply to this message
Old 01-30-2008, 04:30 PM   #7
REDNECK Charger
Senior Member
 
REDNECK Charger's Avatar
 
Join Date: Jun 2007
Location: Carleton Place, Ontario
Posts: 486
Cool

My engine light lately has been going on and off.. I get to about 1/2 tank of fuel.. Light comes on.. fill the tank.. light goes off.. Been doing that for about a week now..

I would do the key jiggle and get the CEL code your self. If its a serious code than take to the dealer, This works?
__________________
Cheers..
REDNECK Charger....
drive4als@yahoo.ca
If ya can't stand behind our Troops.. then try to stand in front of them....
REDNECK Charger is offline   Reply With Quote Quick reply to this message
Old 01-30-2008, 04:35 PM   #8
Ksleigh
Senior Member
 
Ksleigh's Avatar
 
Join Date: Apr 2007
Location: BKLYN
Posts: 860
Quote:
Originally Posted by REDNECK Charger View Post
My engine light lately has been going on and off.. I get to about 1/2 tank of fuel.. Light comes on.. fill the tank.. light goes off.. Been doing that for about a week now..

I would do the key jiggle and get the CEL code your self. If its a serious code than take to the dealer, This works?
??????????
Ksleigh is offline   Reply With Quote Quick reply to this message
Old 01-31-2008, 07:03 AM   #9
jarpod
Senior Member
 
jarpod's Avatar
 
Join Date: Sep 2006
Location: YOU SEE??? IM NOT A BANNED USER
Posts: 1,606
Send a message via Yahoo to jarpod
and I quote:
Quote:
Originally Posted by wickedchargerrt View Post
I've done hundreds of these and its always been fixed with just the update. Thats weird. Its possible you have a bad switch but like i said i've done lots through the bcm update and all were fine. Besides if the switch were bad it would be done for good.
BCM is body control module which runs all interior accesories and wipers.

To everyone, not just jarpod:
ONce again, not being mean to you jarpod, but i've told hundreds of times on this forum that the battery cable pulling is dumb and has zapped many modules i've seen. Especially dont want to pull that cable within an hour of driving the vehicle as almost 20 modules are still running and anyone that knows electronics knows if you pull the ground the ground circuit has to be supressed somehow. Electricity doesnt just stop flowing when the cable is pulled it has to rest somewhere. Please quit pulling cables everyone thinking its the magic fix for everything. The car is not a program of windows where unplugging things makes it go away. Ok i'm done

The dtc pulling above wont acess bcm codes, only pcm codes and communications codes. I dont believe i 've ever gotten a body code from the evic.

Back to the switch thing. IF you want to get into pulling the door panel and diaging this issue i can walk you through it but you'll need a dvom, and you'll have to pull the door panel. The door panel on caravans have *****y clips that like to break and if you have a town and country you dont want to pull the panel if you dont have to that gets into a whole other bag of worms.

Here is my next idea in lieu of the bcm replacement. The bcm is located above where your left foot would sit while driving down the road. Get to this where you can see it. Get the door locks to screw up, then smack the pudding out of the bcm , if this gets them working again you have a bad contactor switch internal to the bcm and you will need to replace.
you actually learn stuff in here, so that is why I didn't suggested to disconnect the battery
hope it helps
__________________
Waiting for:
2009 Jeep Liberty limited custom built with every single factory option there is.

All Gone
2006 Silver R/T with factory Uconnect and sunroof
jarpod is offline   Reply With Quote Quick reply to this message
Old 01-31-2008, 08:06 AM   #10
tbest
Senior Member
 
tbest's Avatar
 
Join Date: Apr 2007
Location: NW
Posts: 152
I have also had the light come on a few times and it was fuel related. All I had to do was take the gas cap off, then put it back on and give it a good 5 turns. Sometimes you have to go a few miles down the road, but the light will go off. In Oregon it is illegal to pump your own gas, so after the attendent fills my tank, I always give it a few extra turns.
__________________
06 Dodge Charger 3.5L HO, D'Molded, Honeycomb Grill Insert, 20% Tint, Daytona Wheels & TOYO Tires
tbest is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 

Reply

  Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Charger Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light - How to Check Codes PikeBoy98 V6 Specific Discussion 23 09-24-2011 04:08 PM
B&G Can Turn Off The Long Tube "Check Engine" Light! tbyrne Charger SRT-8 Discussion 30 08-26-2007 10:21 AM
Check engine light Wakito Charger Problems/Assistance 2 06-10-2007 07:55 PM
Check Engine Light On torkin Charger SRT-8 Discussion 2 09-27-2006 07:05 PM
Check engine light BLUCHARGER General Charger Discussion 3 11-20-2005 09:28 PM

» Recent Discussions
Oracle color shift in...
Yesterday 11:19 PM
Last post by Brian_Gallagher
Yesterday 11:19 PM
0 Replies, 39 Views
89 Octane...
Yesterday 02:17 PM
Last post by Yuro
Yesterday 11:09 PM
7 Replies, 131 Views
Tailights Randomly...
09-02-2014 12:12 AM
by PUREVIL
Last post by PUREVIL
Yesterday 10:16 PM
2 Replies, 254 Views
Some upgrades to my 13...
09-10-2014 02:31 PM
Last post by MR.Super Bee
Yesterday 09:37 PM
15 Replies, 698 Views
some srt8 parts for...
09-29-2014 08:46 AM
Last post by 08daytona#1247
Yesterday 09:34 PM
8 Replies, 359 Views
Mopar CAI worth the...
Yesterday 09:31 PM
by Szeged
Last post by Szeged
Yesterday 09:31 PM
0 Replies, 40 Views
New 2014 Charger Max ?
Yesterday 08:50 PM
Last post by Ddaddy
Yesterday 08:59 PM
1 Replies, 47 Views
ESP not shutting off
Yesterday 08:29 PM
Last post by Ddaddy
Yesterday 08:56 PM
3 Replies, 51 Views
New Site Upgrade and...
09-23-2014 08:21 AM
by AG Jeff
Last post by mnunes
Yesterday 08:39 PM
107 Replies, 2,672 Views
DDTTE! (Don't Delete...
07-28-2011 09:08 PM
by mnunes
Last post by Ddaddy
Yesterday 08:36 PM
6 Replies, 490,916 Views
Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 12:23 AM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
© AutoGuide