Oil Pressure PSI ? 5.7 hemi - Dodge Charger Forums
Charger Problems/Assistance You having problems with your Charger? Check and see if it is a common problem and get answers here.

Reply
 
Thread Tools Search this Thread Display Modes
#1 Old 03-19-2007, 04:07 AM
Mecha
Senior Member
 
Mecha's Avatar
 
Join Date: Jan 2007
Location: Seattle, Wa
Posts: 3,099
(Thread Starter)
Oil Pressure PSI ? 5.7 hemi

notced today my Oil Pressure PSI.
warmed up and at idle im at 15-16 psi
at cruise and accelerating im at 45-48 psi

is that the same some of you are getting with your 5.7 hemi?
Mecha is offline  
Sponsored Links
Advertisement
 
#2 Old 03-19-2007, 04:33 AM
PRoBLeMz
Senior Member
 
PRoBLeMz's Avatar
 
Join Date: Jul 2006
Location: Killeen, TX
Posts: 1,892
your in the norms

Dodge Challenger 392 SRT8(Green w/Envy) Mods soon to follow!
All names changed to protect the Innocent
PRoBLeMz is offline  
#3 Old 03-19-2007, 06:13 AM
arfur
Supporting Member (Lifetime)
 
arfur's Avatar
 
Join Date: Nov 2005
Location: Daventry and Cranfield
Posts: 20,883
Looks good to me...


Don't Hassle the HOFF

Arf - expert in and
arfur is offline  
#4 Old 03-19-2007, 06:24 AM
Black R/T R&T
Senior Member
 
Black R/T R&T's Avatar
 
Join Date: Jun 2005
Location: PA
Posts: 884
That is the range mine was at too. When I switched to Royal purple, 5w20, idle went up to about 21-23, and I have seen 60 under acceleration.

2013 Charger R/T MAX -- Bright White
Black R/T R&T is offline  
#5 Old 03-19-2007, 08:29 AM
HemiChemi
Senior Member
 
HemiChemi's Avatar
 
Join Date: Nov 2005
Location: I don't argue with fools!
Posts: 13,222
Mine are usually a bit higher, but yours seem OK. I see low 20s at idle and high 50s cruising.

Inferno R/T+R&T, EVIC; 6-disk CD; Sirius; UConnect; Protect Gp; front and rear spoilers, Daytona grille and insert, R/T emblem and hidden trailer hitch.
.

There are 10 possibilities:
you either understand binary, or you don't.

HemiChemi is offline  
#6 Old 12-15-2014, 07:09 PM
PAMUNOZ
Junior Member
 
PAMUNOZ's Avatar
 
Join Date: Nov 2014
Location: Toronto
Posts: 17
2007 RT here. My oil pressure usually hovers at 55p range regardless on whether I am idle or not. The odd time I see it go down to lower levels but not often. I just turned on my car about 2 mins ago and the oil pressure is 53p, and I am just idling. Hope that's not cause for concern for me.
Attached Thumbnails
Click image for larger version

Name:	1418691974224.jpg
Views:	36
Size:	45.0 KB
ID:	154961  
PAMUNOZ is online now  
#7 Old 12-15-2014, 08:42 PM
Ddaddy
Supporting Member (Lifetime)
 
Ddaddy's Avatar
 
Join Date: May 2009
Location: Philly PA
Posts: 13,310
Garage
This might be a new record...revived a 7-1/2 year old thread!





BTW, your oil pressure is just fine.
Attached Thumbnails
Click image for larger version

Name:	Zombie thread 1.jpg
Views:	224
Size:	194.2 KB
ID:	154977  


2006 Inferno Red SRT-8
Option groups I, II, & III + Sunroof
Built Thursday February 23, 2006
Triple A Performance (AirFunnel, AirHog, Aces IV)


I will drive her until one of us dies! 1/4 mile: 13.388 secs@105.75 mph
Ddaddy is online now  
#8 Old 12-15-2014, 09:21 PM
PAMUNOZ
Junior Member
 
PAMUNOZ's Avatar
 
Join Date: Nov 2014
Location: Toronto
Posts: 17
LOL I actually google searched the topic... took me right back to this forum/topic! Anyway thanks good to know. Whew.
PAMUNOZ is online now  
#9 Old 01-18-2015, 07:52 AM
abdul aziz
Junior Member
 
Join Date: Jan 2015
Posts: 2
oil pressure senor

i have 2006 chrysler 300c hemi RWD i live in saudia arabia before 2 days i changed the oil sensor due to code and oil leakage from sensor. on old sensor she was giving me 200-250 kpa after warming the car but after changing the sensor she's is giving me 70-80 kpa. is it normal? on full acceleration she is doing 350-400 kpa. please help me
abdul aziz is offline  
#10 Old 01-18-2015, 01:33 PM
370 HEMI
Supporting Vendor
 
370 HEMI's Avatar
 
Join Date: Jun 2006
Location: NE Ohio
Posts: 7,328
Quote:
Originally Posted by abdul aziz View Post
i have 2006 chrysler 300c hemi RWD i live in saudia arabia before 2 days i changed the oil sensor due to code and oil leakage from sensor. on old sensor she was giving me 200-250 kpa after warming the car but after changing the sensor she's is giving me 70-80 kpa. is it normal? on full acceleration she is doing 350-400 kpa. please help me
The rule of thumb here is 10 lbs of oil pressure per 1000 rpm.

Since you are at 200-250 kilopascals we would convert that from kpa to psi

so 200 x .145 = 29 psi to 300 x .145 = 43.5 psi.

80 kpa x .145 = 11.6 psi in idle is still fine.

400 kpa in full acceleration is 400 x .145 = 58 psi.

5,500 rpm x 10 psi per 1000 = 55 so you are fine!

Regards,
Brian
BND Automotive LLC
440-821-9040
www.bndautomotive.com


More Power, More Torque, Better MPGs - It's "Rocket Fuel For Your Car"


Custom Designed & Custom Blended "ALWAYS beats off the shelf brands"

Better cooling, better protection without all "The Gunk"
370 HEMI is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Charger Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
First Oil Change to Royal Purple - lost oil PSI at idle REB Performance Discussion/Modifications 33 11-01-2010 07:45 AM
Oil Pressure budoinst Charger SRT-8 Discussion 5 08-21-2006 06:30 PM
oil pressure johnrx Charger Problems/Assistance 12 02-21-2006 10:18 PM
The Max Inflatable pressure posted on my R/T is 51 PSI! Butter06 Performance Discussion/Modifications 35 12-02-2005 08:27 PM
Oil Pressure moparfan Charger SRT-8 Discussion 11 10-29-2005 10:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome