Oil Pressure Sender Switch code....again. - Dodge Charger Forums
Are you interested in the Dodge Challenger? Visit the Challenger Forum @ ChallengerTalk.com for your Dodge Challenger information!
Dodge Charger Forum Header Dodge Charger Header Right
 


Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

ChargerForums.com is the premier Dodge Charger Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 06-22-2011, 01:29 PM
sector 2's Avatar
sector 2 sector 2 is online now
Senior Member
 
Join Date: Aug 2008
Location: N 21*22.785 /W 157*45.970
Posts: 1,466
Oil Pressure Sender Switch code....again.

My sensor codes 0520 / 0522 keep coming back, even though I changed it. Since installing the new sensor, I have pulled it out and examined it. Seems okay, maybe I got a bad one.....or it is a bad wiring harness. Anyone have this recurring problem. My car has 91k. I wonder if it is actually the sensor or some other problem at high miles. The original sensor had oil leaking through, so I don't know how that may have impacted the second / replacement sensor. I thought I cleaned out the connectors good, but I'll give it one more cleaning and re-inspect the harness......Any thoughts, thanks.


PS...it IS relatively easy to change and you do not have to remove the alternator. Just go from the front w/ a 27mm socket and it will come right out. You just have to fool w/ the wiring harness.
__________________
2013 Charger R/T: (Super Track Pack, Forged Aluminum Wheels) DS catch can / Mopar CAI / SLP Loud Mouth II /powder coated calipers & R1 brake package {slotted rotors - Stop Tech pads - SS lines} ACES IV & QB oils....
Gone and missed...2007 RT


Marine Corps Combat Vet Plates...Live Free Or Die!!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 06-23-2011, 03:22 PM
sector 2's Avatar
sector 2 sector 2 is online now
Senior Member
 
Join Date: Aug 2008
Location: N 21*22.785 /W 157*45.970
Posts: 1,466
Bump...anyone else had similar experience...trying to avoid the dealer, as I just purchased a new sensor. But I may have to take it in to ensure it is not an actual serious problem.
__________________
2013 Charger R/T: (Super Track Pack, Forged Aluminum Wheels) DS catch can / Mopar CAI / SLP Loud Mouth II /powder coated calipers & R1 brake package {slotted rotors - Stop Tech pads - SS lines} ACES IV & QB oils....
Gone and missed...2007 RT


Marine Corps Combat Vet Plates...Live Free Or Die!!
Reply With Quote Quick reply to this message
  #3  
Old 06-24-2011, 09:25 PM
sector 2's Avatar
sector 2 sector 2 is online now
Senior Member
 
Join Date: Aug 2008
Location: N 21*22.785 /W 157*45.970
Posts: 1,466
Help Guys!!
__________________
2013 Charger R/T: (Super Track Pack, Forged Aluminum Wheels) DS catch can / Mopar CAI / SLP Loud Mouth II /powder coated calipers & R1 brake package {slotted rotors - Stop Tech pads - SS lines} ACES IV & QB oils....
Gone and missed...2007 RT


Marine Corps Combat Vet Plates...Live Free Or Die!!
Reply With Quote Quick reply to this message
  #4  
Old 03-02-2012, 04:28 PM
MDK's Avatar
MDK MDK is offline
Junior Member
 
Join Date: Jan 2012
Posts: 2
any luck on this? I just got that code again after swapping out the sensor about a month ago... like the 3rd time replacing this in the last six months
Reply With Quote Quick reply to this message
  #5  
Old 03-05-2012, 11:15 AM
eggsandbacon eggsandbacon is offline
Senior Member
 
Join Date: Feb 2010
Location: Brooklyn, NY
My Charger: 06 rt
Posts: 398
have you guys tried to clear the codes after the install? sometimes that helps.
Reply With Quote Quick reply to this message
  #6  
Old 03-05-2012, 11:17 AM
eggsandbacon eggsandbacon is offline
Senior Member
 
Join Date: Feb 2010
Location: Brooklyn, NY
My Charger: 06 rt
Posts: 398
any electrical things i would have the dealer do, so if they mess up its under warranty. and if u pay for diagnostic then you could use that money towards repairs and if u think you can do the repair yourself then have them do a tranmission flush or something. thats what i would do.
Reply With Quote Quick reply to this message
  #7  
Old 08-25-2012, 08:08 AM
Houston_Hemi's Avatar
Houston_Hemi Houston_Hemi is offline
Senior Member
 
Join Date: Jan 2007
Location: Houston
Posts: 422
Well,

I changed the alternator, and had to unplug the sensor. After hooking everything back in, now my sensor is activating the engine light. I surely don't want to spend time switching this thing out if it won't work. It's a pain to get to..
__________________


105k miles, and still running strong..
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 

Reply

  Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Charger Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure Sender Leak SXTman09 Charger Problems/Assistance 1 05-25-2010 08:45 AM
oil pressure code ? R/TwagonScott Charger Problems/Assistance 2 03-02-2010 07:32 PM
P0521 Engine Oil Pressure Performance Code youaintpimp Charger Problems/Assistance 1 09-24-2008 03:40 PM
a switch is a switch is a switch? nitrous controls/halos/etc? sandt Interior Discussion/Modifications 14 03-27-2008 10:58 AM
ZEX kit, window switch, opener, heater, pressure on demand dennyt4 Parts For Sale/Wanted 26 01-14-2008 01:14 PM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 04:36 AM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© AutoGuide