Oil Pressure Sender Switch code....again. - Dodge Charger Forums
Charger Problems/Assistance You having problems with your Charger? Check and see if it is a common problem and get answers here.

 
Thread Tools Search this Thread Display Modes
post #1 of 7 Old 06-22-2011, 01:29 PM Thread Starter
sector 2
Senior Member
 
sector 2's Avatar
 
Join Date: Aug 2008
Location: N 21*22.785 /W 157*45.970
Posts: 1,564
(Thread Starter)
Oil Pressure Sender Switch code....again.

My sensor codes 0520 / 0522 keep coming back, even though I changed it. Since installing the new sensor, I have pulled it out and examined it. Seems okay, maybe I got a bad one.....or it is a bad wiring harness. Anyone have this recurring problem. My car has 91k. I wonder if it is actually the sensor or some other problem at high miles. The original sensor had oil leaking through, so I don't know how that may have impacted the second / replacement sensor. I thought I cleaned out the connectors good, but I'll give it one more cleaning and re-inspect the harness......Any thoughts, thanks.


PS...it IS relatively easy to change and you do not have to remove the alternator. Just go from the front w/ a 27mm socket and it will come right out. You just have to fool w/ the wiring harness.

2013 Charger R/T: (Super Track Pack, Forged Aluminum Wheels) DS catch can / Mopar CAI / SLP Loud Mouth II /powder coated calipers & R1 brake package {slotted rotors - Stop Tech pads - SS lines} ACES IV & QB oils....
Gone and missed...2007 RT


Marine Corps Combat Vet Plates...Live Free Or Die!!
sector 2 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old 06-23-2011, 03:22 PM Thread Starter
sector 2
Senior Member
 
sector 2's Avatar
 
Join Date: Aug 2008
Location: N 21*22.785 /W 157*45.970
Posts: 1,564
(Thread Starter)
Bump...anyone else had similar experience...trying to avoid the dealer, as I just purchased a new sensor. But I may have to take it in to ensure it is not an actual serious problem.
sector 2 is offline  
post #3 of 7 Old 06-24-2011, 09:25 PM Thread Starter
sector 2
Senior Member
 
sector 2's Avatar
 
Join Date: Aug 2008
Location: N 21*22.785 /W 157*45.970
Posts: 1,564
(Thread Starter)
Help Guys!!
sector 2 is offline  
post #4 of 7 Old 03-02-2012, 04:28 PM
MDK
Junior Member
 
MDK's Avatar
 
Join Date: Jan 2012
Posts: 2
any luck on this? I just got that code again after swapping out the sensor about a month ago... like the 3rd time replacing this in the last six months
MDK is offline  
post #5 of 7 Old 03-05-2012, 11:15 AM
eggsandbacon
Senior Member
 
Join Date: Feb 2010
Location: Brooklyn, NY
Posts: 400
have you guys tried to clear the codes after the install? sometimes that helps.
eggsandbacon is offline  
post #6 of 7 Old 03-05-2012, 11:17 AM
eggsandbacon
Senior Member
 
Join Date: Feb 2010
Location: Brooklyn, NY
Posts: 400
any electrical things i would have the dealer do, so if they mess up its under warranty. and if u pay for diagnostic then you could use that money towards repairs and if u think you can do the repair yourself then have them do a tranmission flush or something. thats what i would do.
eggsandbacon is offline  
post #7 of 7 Old 08-25-2012, 08:08 AM
Houston_Hemi
Senior Member
 
Houston_Hemi's Avatar
 
Join Date: Jan 2007
Location: Houston
Posts: 425
Well,

I changed the alternator, and had to unplug the sensor. After hooking everything back in, now my sensor is activating the engine light. I surely don't want to spend time switching this thing out if it won't work. It's a pain to get to..



105k miles, and still running strong..
Houston_Hemi is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Quick Reply

User Tag List

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil Pressure Sender Leak SXTman09 Charger Problems/Assistance 1 05-25-2010 08:45 AM
oil pressure code ? R/TwagonScott Charger Problems/Assistance 2 03-02-2010 07:32 PM
P0521 Engine Oil Pressure Performance Code youaintpimp Charger Problems/Assistance 1 09-24-2008 03:40 PM
a switch is a switch is a switch? nitrous controls/halos/etc? sandt Interior Discussion/Modifications 14 03-27-2008 10:58 AM
ZEX kit, window switch, opener, heater, pressure on demand dennyt4 Parts For Sale/Wanted 26 01-14-2008 01:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome