Help! Car won't go over 35mph? - Dodge Charger Forums
Charger Problems/Assistance You having problems with your Charger? Check and see if it is a common problem and get answers here.

Reply
 
Thread Tools Search this Thread Display Modes
#1 Old 06-09-2010, 11:53 AM
GS4life
Junior Member
 
Join Date: Jun 2010
Posts: 3
(Thread Starter)
Help! Car won't go over 35mph?

Hi Guys,

I'm new to the forum, my brother has a 2007 Charger Base with the 3.5 in it. Over the 3 year lease, the car has been in at least 4 times for the same problem. Sometimes, the engine light will come on and it will not accelerate past 35mph. The lease it up and the plan was to buy out the car for 12K, he really likes it and has some mods on it, but once again, the light has come one and the car will not exceed 35mph again. Should i give the car back and run? Has anyone else had this problem? Advice please. It has 38K on it, so its out of warranty.
GS4life is offline  
Sponsored Links
Advertisement
 
#2 Old 06-09-2010, 12:12 PM
Jonny
Supporting Member (Lifetime)
 
Jonny's Avatar
 
Join Date: Mar 2008
Location: Upstate NY
Posts: 8,720
Its going into limp mode for some reason. Limp mode protects the car from further damage, letting the owner know it needs to be serviced. There are many reasons this can happen. Did the dealer just reset it or fix the original problem that caused it to go into limp mode.... ?

I am the Stig

2010 R/T DWBlue, 2800 PI stall, Homemade CAI, JBA headers and mids, SLP LMII catback, Custom tune by Diablotoona, 180 T-stat, 3.06 Getrag.
Jonny is offline  
#3 Old 06-09-2010, 12:16 PM
Ron380
Senior Member
 
Ron380's Avatar
 
Join Date: Aug 2007
Location: Dayton, OH.
Posts: 7,360
The car will go into "Limp Mode" if it senses wheel spin or over-revving the throttle. What's your brother's driving style? Does he hammer on the car occasionally? If so, the car is just doing what it's supposed to do to prevent damage to the engine or transmission.


2007 TorRed SXT/AWD: Gone, but not forgotten.
2011 Mustang GT, Kona Blue
2007 Ram 1500 4x4, 4.7l V8. mods have started...
Ron380 is offline  
#4 Old 06-09-2010, 01:36 PM
GS4life
Junior Member
 
Join Date: Jun 2010
Posts: 3
(Thread Starter)
Thanks for the insight. To be honest, he drives like an old lady. He never really speeds and floors the car, mainly cause its the 3.5. He has 22 inch rims on it, but i know alot of people with 22s on their chargers and they are fine. This is very odd....
GS4life is offline  
#5 Old 06-09-2010, 01:54 PM
Stylz
Senior Member
 
Join Date: Aug 2009
Location: Nor-Cal
Posts: 140
I dont have 22 inch rims, but i remember talking to the service manager of Chrysler Jeep of San Francisco and he told me that cars who have rims of a size of 22 and larger sometimes have problems with their ABS (due to all the hills etc. here). There are tons of guys who dont have problems, but i just wanted to contribute my 2 cents.

Also, are the rims staggered and was the computer adjusted for the tire sizes? if the tire sizes are different front to rear and the computer is not set up for it, it might give a reading to your abs that your car's tires are spinning while they are really not. Again, this might have nothing to do with it, but just my 2 cents.

ps welcome to the forum!


2006 Torred Dodge Charger Daytona #1820
Mods: AFE Stage II CAI, Corsa Exhaust, Mopar Strut Tower Brace, Mopar Sway Bars, 20 inch Factory Reproductions SRT8 Wheels wrapped with 275 40 ZR 20 Vredestein Ultrac Sessanta tires, Custm Painted Brake Calipers, Stillen Front Brake Rotors and Mopar Pads, Power Window Switch Covers. Car mods are done!!!... For now...
Stylz is offline  
#6 Old 06-09-2010, 02:20 PM
DjMere
Senior Member
 
DjMere's Avatar
 
Join Date: May 2010
Location: Hayward, Ca
Posts: 825
i have 22"s & i drive in SF all the time. no problems here

2009 HEMI ORANGE SRT Super Bee
Basics: Fully Loaded, Nav, Rear DVD System w/ Headphones, Sunroof, Etc Predator 91CAI Tune / QB Fluids / ACES IV
http://www.mixcrate.com/djmere
DjMere is online now  
#7 Old 06-09-2010, 02:40 PM
SicHemi
Senior Member
 
SicHemi's Avatar
 
Join Date: Jul 2009
Location: Schenectady ny
Posts: 984
Quote:
Originally Posted by Jonny View Post
Its going into limp mode for some reason. Limp mode protects the car from further damage, letting the owner know it needs to be serviced. There are many reasons this can happen. Did the dealer just reset it or fix the original problem that caused it to go into limp mode.... ?
thats what she said...

(sorry)


2006 white R/T with R.T package.(to many mods..not enough room...see my car domain)
My Car Domain
SicHemi is offline  
#8 Old 06-10-2010, 01:50 AM
mighty
Junior Member
 
Join Date: Jun 2010
Posts: 1
I also have 22 inch rims and running perfectly.
Show your problem to some good auto mechanic.
mighty is offline  
#9 Old 06-10-2010, 02:40 AM
sj1400
Senior Member
 
sj1400's Avatar
 
Join Date: Jul 2007
Posts: 143
I ran into this issue when I pulled my car out of storage this year. Car had been sitting for 5 months. Although the battery was weak it had enough charge to start the car. Pulled out hte garage but couldn't get over 25mph.. Turned around - charged battery and restarted the car. No issues.

07 RT w/R&T, sound group 2, electronic conv pkg.
10 Ram 1500 ST Hemi 4x4 Quad Cab
sj1400 is offline  
#10 Old 06-10-2010, 10:14 AM
InvictuSRT8
Supporting Member (Lifetime)
 
InvictuSRT8's Avatar
 
Join Date: Dec 2008
Location: Annapolis, MD
Posts: 5,115
Garage
Send a message via AIM to InvictuSRT8
i had this pretty exact issue, after a replaced battery and some other transmission computer related stuff it was back to normal

it would get stuck at either 35 45 or 55 and stay in either 2nd or 3rd gear (no matter how fast or slow i went)
http://www.youtube.com/watch?v=Hg_YX...layer_embedded

http://www.chargerforums.com/forums/...d.php?t=122996

A modded 06' 370 & an 07' 426
Build Thread/Pikturez, My YouTube
InvictuSRT8 is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Charger Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Breast Cancer Charity Car Cruise & Car Show Signal 20 South Eastern 9 11-01-2009 10:23 AM
Colorado Springs Car show July 3rd held by my car club! greggk South Western 3 07-01-2009 05:55 PM
Car porn from car show HIN w/ sweet models and cars triplblckcharger Picture/Media Post 56 06-21-2009 02:27 PM
Monument Car Parts Car Show Aug. 17th, Pleasanton, CA 07Inferno California 4 08-17-2008 07:15 PM
CEL, no code, won't go >35mph FaZt1 Charger Problems/Assistance 3 12-30-2007 09:51 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome