Speedometer not working - Dodge Charger Forums
Are you interested in the Dodge Challenger? Visit the Challenger Forum @ ChallengerTalk.com for your Dodge Challenger information!
Dodge Charger Forum Header Dodge Charger Header Right
 

Go Back   Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Charger Problems/Assistance You having problems with your Charger? Check and see if it is a common problem and get answers here.

Reply
 
Thread Tools Search this Thread
Display Modes
Old 10-15-2009, 12:51 PM   #1
icecreamhemi
Junior Member
 
Join Date: Nov 2005
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Speedometer not working

I have an 06 charger rt. The speedometer stopped working. Does anyone know what could cause this problem? The dealer says the instrument cluster is bad, but everything on the cluster is working except for the speed. I need a second opinion before I spend $300 on a new cluster.
icecreamhemi is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-15-2009, 07:03 PM   #2
rodneyiii
Senior Member
 
rodneyiii's Avatar
 
Join Date: Aug 2005
Location: Raleigh, NC
Posts: 1,939
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by icecreamhemi View Post
I have an 06 charger rt. The speedometer stopped working. Does anyone know what could cause this problem? The dealer says the instrument cluster is bad, but everything on the cluster is working except for the speed. I need a second opinion before I spend $300 on a new cluster.
The analog gauge might have gone bad. I don't think the car knows if that needle stops working so it wouldn't throw a code. If the speed sensor went out, you would know for sure with a code. Try this cluster test:

Cluster diagnostic.

Press and hold the trip meter reset then turn the key to "ON", the gauges will step through the whole range. If your gauge is acting funny, this is an easy way to see if it's the sender or the gauge.
__________________
2006 Inferno Red SRT8 with groups I, II, Sunroof, K&N drop-in filter, Auto-dim mirror, Jet-180 T-stat, Predator, 300 SRT struts/springs, Chally SRT wheels.
Born 6-21-06, Home 4-26-10. 1/4 mile - 12.989 @ 108.78 in street trim. Traded 10-19-2012.
2006 Inferno Red R/T with R&T Born 8-12-05, Home 8-25-05, Sold 8-9-10.
rodneyiii is offline   Reply With Quote Quick reply to this message
Old 10-16-2009, 08:56 AM   #3
icecreamhemi
Junior Member
 
Join Date: Nov 2005
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I did the cluster diagnostic and the speedometer was the only gauge that didn't respond.
icecreamhemi is offline   Reply With Quote Quick reply to this message
Old 10-16-2009, 09:04 AM   #4
SVRSRTCDN
Senior Member
 
Join Date: Feb 2007
Posts: 767
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Sad to say then, looks like you need a cluster. You could try disconnecting the battery, wait a few min and reconnect. then try the cluster diagnostic again but i doubt it will help.
__________________
Returned 2006 Silver SRT8 (vanished into the unknown!)
2004 Jeep Grand Cherokee Overland
2009 Jeep Patriot Rocky Mountain
1982 Kawasaki KZ1100 Spectre
SVRSRTCDN is offline   Reply With Quote Quick reply to this message
Old 11-26-2009, 04:54 AM   #5
forumoto
Junior Member
 
Join Date: Nov 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by rodneyiii View Post
The analog gauge might have gone bad. I don't think the car knows if that needle stops working so it wouldn't throw a code. If the speed sensor went out, you would know for sure with a code. Try this cluster test:

Cluster diagnostic.

Press and hold the trip meter reset then turn the key to "ON", the gauges will step through the whole range. If your gauge is acting funny, this is an easy way to see if it's the sender or the gauge.
Well I did this diag and my speedometer fead, it goes to 100+ then start to counts down as other clusters count down by jumping one, one one till it rest. please what is next as the speedometer needle read and comes down as the rest comes down. what should be check next
forumoto is offline   Reply With Quote Quick reply to this message
Old 11-26-2009, 06:35 AM   #6
amont5
Junior Member
 
Join Date: Mar 2007
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I had a problem with the speedo on a neon once, i tired to find the link but after everyone including the dealer told me i needed to replace i found a neon fourm that said to hold the trip reset button in then insert the key and cycle off to acc then on and back off. they speedo flung to 100 then rested back to 0 and worked like a charm from then on. dont know if this will work for you but worth a try. good luck

- edit just read the other post--- sorry

Last edited by amont5; 11-26-2009 at 06:37 AM.
amont5 is offline   Reply With Quote Quick reply to this message
Old 11-26-2009, 11:35 AM   #7
forumoto
Junior Member
 
Join Date: Nov 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I have done the above stated diagnoses and mine flung to 100 then to 0, yet still the speedometer can rise, i have the car raise up in the air while i do this as i am aware the rear pushes the car, so with the car being in air, and the tires rolling i expect to see the speedometer reading... please keep the suggestion coming
forumoto is offline   Reply With Quote Quick reply to this message
Old 11-26-2009, 11:48 AM   #8
Vito
Senior Member
 
Vito's Avatar
 
Join Date: Oct 2009
Location: Boston
Posts: 6,132
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Send a message via AIM to Vito
bring it to the dealer its probably just tripped
__________________

I really Hate Mustangs, Especially Cobras
True||Street||Cars
1000+ RWHP Twin Turbo SRT-8 In The Making
Vito is offline   Reply With Quote Quick reply to this message
Old 11-26-2009, 11:57 AM   #9
forumoto
Junior Member
 
Join Date: Nov 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Tripped, come on i needed help that is why i am on here, i know there are dealership but i must get it through first
forumoto is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 

Reply

  Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Charger Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Metric Speedometer - where can I get a metric speedometer face? drjimmy General Charger Discussion 14 03-06-2008 03:07 PM
Speedometer? Phlipbak Wheels/Tires/Brakes/Suspension 1 03-05-2008 08:54 AM
MDS working / not working. Going to dealer PLUM CRZY 1074 Charger Problems/Assistance 8 02-15-2008 07:56 AM
speedometer cientifik12 Charger SRT-8 Discussion 2 11-19-2007 08:54 PM
Speedometer MexCharger Interior Discussion/Modifications 3 07-19-2007 05:25 PM

» Recent Discussions
Reprogram 2007 PCM to...
09-03-2014 02:18 AM
Last post by myofrost
Today 12:08 AM
17 Replies, 715 Views
3.5L V6 Exhaust Options?
09-14-2014 06:31 PM
Last post by torred 3.5
Yesterday 11:36 PM
4 Replies, 229 Views
Hi Flow Cats?
09-26-2014 09:46 PM
by Bub25
Last post by kar1zma
Yesterday 11:35 PM
4 Replies, 221 Views
Considering lowering...
Yesterday 01:45 AM
Last post by CaliforniaCharger
Yesterday 11:21 PM
9 Replies, 494 Views
Help With photoshopping...
09-10-2014 07:43 AM
Last post by CaliforniaCharger
Yesterday 11:16 PM
24 Replies, 955 Views
2014 3.6L -- Help,...
09-16-2014 07:25 PM
Last post by rickjesp
Yesterday 11:15 PM
2 Replies, 352 Views
Hemi Engine noise..
09-29-2014 06:53 PM
Last post by richd
Yesterday 10:42 PM
11 Replies, 379 Views
How to Install Interior...
09-22-2014 06:47 PM
Last post by mnunes
Yesterday 10:36 PM
5 Replies, 310 Views
How do I..... EVERYTHING!
02-23-2008 09:26 PM
by mnunes
Last post by mnunes
Yesterday 10:35 PM
523 Replies, 298,993 Views
Auto Door Locks - only...
Yesterday 07:52 PM
Last post by tanbam
Yesterday 10:25 PM
2 Replies, 57 Views
Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 02:11 AM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
User Alert System provided by Advanced User Tagging (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
© AutoGuide