Can't find my owners manual...dash light indicator?? - Dodge Charger Forums
Charger Problems/Assistance You having problems with your Charger? Check and see if it is a common problem and get answers here.

 
Thread Tools Search this Thread Display Modes
#1 Old 10-03-2009, 01:44 PM
hus
Junior Member
 
Join Date: Jan 2008
Posts: 22
(Thread Starter)
Can't find my owners manual...dash light indicator??

I don't know where my owner's manual went Can someone look and tell me what the symbol with exclamation point with like a horseshoe around it and wavey lines at the bottom mean? Kind of like this but with the wavey line at the bottom ---> (!) Thanks!

2007 Plum Crazy Daytona 0740/1400
hus is offline  
Sponsored Links
Advertisement
 
#2 Old 10-03-2009, 01:47 PM
Blue Phantom
Senior Member
 
Blue Phantom's Avatar
 
Join Date: Sep 2008
Location: No Calif.
Posts: 399
You can download the whole owners manual from the Dodge.com website. Go to the owners section.


2008 R/T Steel Blue
Blue Phantom is offline  
#3 Old 10-03-2009, 01:55 PM
hus
Junior Member
 
Join Date: Jan 2008
Posts: 22
(Thread Starter)
Nevermind. My wife found the manual right after I posted this. I was getting frustrated about the manual. My tire pressure's low.
hus is offline  
#4 Old 10-03-2009, 02:00 PM
Gabe
Senior Member
 
Gabe's Avatar
 
Join Date: May 2007
Location: MA
Posts: 13,450
Quote:
Originally Posted by hus View Post
I don't know where my owner's manual went Can someone look and tell me what the symbol with exclamation point with like a horseshoe around it and wavey lines at the bottom mean? Kind of like this but with the wavey line at the bottom ---> (!) Thanks!
(.!.) .... supposed to resemble a cross-section of a tire ... yeah, it's the "tire pressure low" light

- Former owner of a 2007 Charger R/T AWD -


Mine: '13 Mustang GT, Sterling Gray, MT82, Recaros, Track Pk. Mine 8.11.12 ... now w/2.3L Whipple, VMP h.e., 591 RWHP, 505 RWTQ. '06 Tundra 4x4 V8 AccessCab. Silver.
Hers: '08 GT500, White/blue stripes, pulley/JLT CAI/tune, 560+RWHP/550+RWTQ. '03 Forester, green, 5-speed.
Gabe is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Charger Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



User Tag List

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question About Malfunction Indicator Light Synner Charger Problems/Assistance 26 11-14-2013 06:54 AM
Hi Beam indicator light when using turnsignal bigmike1975 Charger Problems/Assistance 5 03-26-2008 12:37 PM
Malfunction Indicator Light-wtf litlshrub Charger Problems/Assistance 8 10-13-2007 07:35 PM
MDS Indicator Light Todd 06R/T R&T Performance Discussion/Modifications 5 08-01-2007 10:37 PM
OBD engine indicator light?? LILGTO Charger Problems/Assistance 6 03-01-2007 04:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome