Low Oil Pressure at idle, oil light comes on too - Dodge Charger Forums
Are you interested in the Dodge Challenger? Visit the Challenger Forum @ ChallengerTalk.com for your Dodge Challenger information!
Dodge Charger Forum Header Dodge Charger Header Right
 


Auto Insurance

» Featured Product
Wheel & Tire Center

Go Back   Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Charger Problems/Assistance You having problems with your Charger? Check and see if it is a common problem and get answers here.

ChargerForums.com is the premier Dodge Charger Forum on the internet. Registered Users do not see the above ads.
Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 03-30-2009, 10:53 AM
danaM's Avatar
danaM danaM is offline
Senior Member
 
Join Date: Oct 2005
Location: Columbus, Ohio
Posts: 2,201
Thanks: 0
Thanked 0 Times in 0 Posts
Low Oil Pressure at idle, oil light comes on too

Greetings,

My engine light and oil light have been coming on the last few days. (Have not pulled h codes yet) and my oil pressure is real low - 4 to 5 PSI at idle after the car is running for a few minutes.

I just had plugs changes for he 30 k service. I also switched form Royal Purple (K&N filter) to Amsoil (Amsoil filter) 5w20 Synthetic when I got the plugs changed out.

The stick actually reads more than full. Could this be the cause?

Thx!
D a n a
__________________
Genius is one percent inspiration and ninety-nine percent perspiration!

Thomas Alva Edison

Damn, I love my Charger!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 03-30-2009, 10:56 AM
thumper07's Avatar
thumper07 thumper07 is offline
Senior Member
 
Join Date: Feb 2008
Location: Sammy Hagarville, SFL
Posts: 5,734
Thanks: 0
Thanked 0 Times in 0 Posts
How much past the full mark is it? A quarts worth? Do you check it after you let it idle for 5 minutes? I'm no mechanic, but I'd venture to guess that if it's WAY overfilled, it can cause problems. I underfill mine if anything.
__________________
2007 R/T | Diablo 93CAI | AFE Stage II CAI | Flowmaster Super 44 Catback | SLP Udrive Pulley | BT Catch Can
Blacked out 20x9 SRT wheels | Toaster Mod | Clock Tower Mod
Best pre pulley 1/4: 13.64 @ 101.33 mph

If you don't like what I'm saying, my response can be re-calibrated. Turn the ignition key to the ON position. Re-read my post and at the same time turn the key to the ACC position. My response has now been re-calibrated.
Reply With Quote Quick reply to this message
  #3  
Old 03-30-2009, 03:50 PM
xtcbct's Avatar
xtcbct xtcbct is offline
Supporting Member (Lifetime)
Lifetime Supporting Member
 
Join Date: Jul 2008
Location: Eastern Conn.
Posts: 702
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via AIM to xtcbct
Dana,

What made you switch from RP to Amsoil just out of curiousity?

Xian
__________________
2006 Dodge Charger R/T Daytona Edition
1773 of 4000
Mods:
Front Blinker Mod, Elite22 Console cover, Side Body Molding delete, BWoody Sway Bar End Links, Mopar CAI

Beater Car: 2003 Ford Crown Victoria LX
Bone Stock!!
Reply With Quote Quick reply to this message
  #4  
Old 03-30-2009, 04:11 PM
TripleTransAm's Avatar
TripleTransAm TripleTransAm is offline
Senior Member
 
Join Date: Jun 2006
Location: Montreal, Quebec, Canada
Posts: 3,852
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by danaM View Post
My engine light and oil light have been coming on the last few days. (Have not pulled h codes yet) and my oil pressure is real low - 4 to 5 PSI at idle after the car is running for a few minutes.
I don't see how a too-full dipstick reading would result in low oil pressure.

Have you been driving the car in this condition? If so, you're asking for WAY bigger problems if there is in fact a real problem. Is your engine noisier than usual when this happens?

Seriously, I would have had the car flatbed'ed to a dealer in order to determine whether it was a simple case of failure of the oil pressure sender or if you really do have super low oil pressure for some other reason. And if you do have a real problem with oil pressure, chances are if you drove the car in this condition you've already messed something else up big time.
__________________
/Steve
1987 Pontiac Trans Am GTA
1998 Pontiac Trans Am WS6
1978 Pontiac Trans Am
1978 Pontiac Trans Am 4-speed SE
2006 Daytona R/T Tor-Red (59 of 200 - Canadian)
Reply With Quote Quick reply to this message
  #5  
Old 03-30-2009, 04:54 PM
danaM's Avatar
danaM danaM is offline
Senior Member
 
Join Date: Oct 2005
Location: Columbus, Ohio
Posts: 2,201
Thanks: 0
Thanked 0 Times in 0 Posts
Oil light just came on yesterday. Idle is fine when I am driving the car. It is a very low Idle when stopping, goes down to like 2 to 3 psi and then the oil light comes on. I have not been driving it very much before the light came on or after.

I just picked it up from the dealership last Wednesday. It is in no way damaged, the engine sounds healthy and strong, no loss of power, just the light and the low idle when coming to a stop.

D a n a



Quote:
Originally Posted by TripleTransAm View Post
I don't see how a too-full dipstick reading would result in low oil pressure.

Have you been driving the car in this condition? If so, you're asking for WAY bigger problems if there is in fact a real problem. Is your engine noisier than usual when this happens?

Seriously, I would have had the car flatbed'ed to a dealer in order to determine whether it was a simple case of failure of the oil pressure sender or if you really do have super low oil pressure for some other reason. And if you do have a real problem with oil pressure, chances are if you drove the car in this condition you've already messed something else up big time.
Reply With Quote Quick reply to this message
  #6  
Old 03-30-2009, 04:58 PM
danaM's Avatar
danaM danaM is offline
Senior Member
 
Join Date: Oct 2005
Location: Columbus, Ohio
Posts: 2,201
Thanks: 0
Thanked 0 Times in 0 Posts
The economy. I am an Amsoil distributor but instead of getting Amsoil synthetic for 4.25 a quart, I have been paying 6.99 or 7.99 for RP eginning wiht my first oil change 3 years ago. I figured I would eat my own dog food, and go wiht the Amsoil, that's all. She does seem to run a little cooler with Amsoil but I have not driven her very much or very far since the switch. You cannot go wrong with either oil. Both products are the best of the best along with M1

D a n a


Quote:
Originally Posted by xtcbct View Post
Dana,

What made you switch from RP to Amsoil just out of curiousity?

Xian

Last edited by danaM; 03-30-2009 at 05:06 PM.
Reply With Quote Quick reply to this message
  #7  
Old 03-30-2009, 05:08 PM
Gabe's Avatar
Gabe Gabe is offline
Senior Member
 
Join Date: May 2007
Location: MA
Posts: 13,446
Thanks: 0
Thanked 0 Times in 0 Posts
See this TSB ... it's about low oil pressure and a re-flash that's available for that ...

http://www.wkjeeps.com/misc/LX/TSB/TSB_1800308.pdf

__________________
- Former owner of a 2007 Charger R/T AWD -


His: '13 Mustang GT Sterling Gray, Track Pack, Recaros, 2.3L Whipple w/10-psi pulley, JLT CAI, ID1000's, JDM tune, 591RWHP, 505RWTQ
Hers: '08 Mustang GT500 White/blue stripes, pulley/CAI/tune, FRPP twin-65mm TB, 560+RWHP, 550+RWTQ
Reply With Quote Quick reply to this message
  #8  
Old 03-30-2009, 05:13 PM
danaM's Avatar
danaM danaM is offline
Senior Member
 
Join Date: Oct 2005
Location: Columbus, Ohio
Posts: 2,201
Thanks: 0
Thanked 0 Times in 0 Posts
the tsb says the update is for the 07 - 08 LXs. Mine is an 06. I wonder if that put's me out of the running to receive it.

D a n a
Reply With Quote Quick reply to this message
  #9  
Old 03-30-2009, 05:16 PM
Gabe's Avatar
Gabe Gabe is offline
Senior Member
 
Join Date: May 2007
Location: MA
Posts: 13,446
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by danaM View Post
the tsb says the update is for the 07 - 08 LXs. Mine is an 06. I wonder if that put's me out of the running to receive it.

D a n a
Well, TSB's are not recalls .... you will most likely only have that done at no charge if your car is still under the original 3/36 warranty ...
Reply With Quote Quick reply to this message
  #10  
Old 03-30-2009, 05:30 PM
YKW's Avatar
YKW YKW is offline
Senior Member
 
Join Date: Nov 2008
Location: Connecticut
Posts: 746
Thanks: 0
Thanked 0 Times in 0 Posts
Could they have knocked off a vacuum or electrical connector when they did the work?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 

Reply

  Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Dodge Charger Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
First Oil Change to Royal Purple - lost oil PSI at idle REB Performance Discussion/Modifications 33 11-01-2010 06:45 AM
oil pressure light comes on snatchss454 Charger Problems/Assistance 4 05-06-2007 09:39 AM
low oil pressure @ idle rogerc5 Charger Problems/Assistance 29 04-16-2007 09:49 PM
Oil pressure at idle?? lkramer18 General Charger Discussion 8 01-22-2007 06:36 AM
Normal low idle oil pressure?? Pontiac_convert Charger Problems/Assistance 18 07-21-2006 05:53 AM

Powered by vBadvanced CMPS v3.2.2

All times are GMT -6. The time now is 10:53 PM.



Powered by vBulletin®. Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© AutoGuide