07 3.5 not running at temp - Dodge Charger Forums
Charger Problems/Assistance You having problems with your Charger? Check and see if it is a common problem and get answers here.

 
Thread Tools Search this Thread Display Modes
post #1 of 9 Old 12-14-2012, 09:02 AM Thread Starter
jhebert
Member
 
Join Date: Dec 2012
Posts: 30
(Thread Starter)
07 3.5 not running at temp

So after a 45 minute drive today I noticed my temp was low. It is cold out but my other cars in the past all reached normal temp. Is this a symptom of a potential problem? Its 35F outside.

Sent from my SAMSUNG-SGH-I747 using AutoGuide.Com Free App
Attached Thumbnails
Click image for larger version

Name:	uploadfromtaptalk1355500926522.jpg
Views:	66
Size:	19.7 KB
ID:	72098  
jhebert is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 12-14-2012, 09:08 AM
Terranova88
Junior Member
 
Join Date: Sep 2011
Posts: 7
Quote:
Originally Posted by jhebert View Post
So after a 45 minute drive today I noticed my temp was low. It is cold out but my other cars in the past all reached normal temp. Is this a symptom of a potential problem? Its 35F outside.

Sent from my SAMSUNG-SGH-I747 using AutoGuide.Com Free App
Mine will get up to there when driving in town then as soon as I hit the freeway (in 32-45 degree mornings) to go to work in the morning it gradually falls then finally hits the lowest point and my ECT light comes on and engine temp is 32 degrees after driving 70mph for 10 minutes. Trying to figure this one out myself.
Terranova88 is offline  
post #3 of 9 Old 12-14-2012, 09:16 AM Thread Starter
jhebert
Member
 
Join Date: Dec 2012
Posts: 30
(Thread Starter)
I didnt get any indicators but it was all freeway driving

Sent from my SAMSUNG-SGH-I747 using AutoGuide.Com Free App
jhebert is offline  
post #4 of 9 Old 12-14-2012, 10:52 AM
rodneyiii
Senior Member
 
rodneyiii's Avatar
 
Join Date: Aug 2005
Location: Raleigh, NC
Posts: 1,969
Sounds like you both need a new thermostat.

2006 Inferno Red SRT8 with groups I, II, Sunroof, K&N drop-in filter, Auto-dim mirror, Jet-180 T-stat, Predator, 300 SRT struts/springs, Chally SRT wheels.
Born 6-21-06, Home 4-26-10. 1/4 mile - 12.989 @ 108.78 in street trim. Traded 10-19-2012.
2006 Inferno Red R/T with R&T Born 8-12-05, Home 8-25-05, Sold 8-9-10.
rodneyiii is offline  
post #5 of 9 Old 01-01-2013, 04:32 PM Thread Starter
jhebert
Member
 
Join Date: Dec 2012
Posts: 30
(Thread Starter)
CEL popped last night, you were rightm

Sent from my SAMSUNG-SGH-I747 using AutoGuide.Com Free App
jhebert is offline  
post #6 of 9 Old 01-02-2013, 11:31 AM
rodneyiii
Senior Member
 
rodneyiii's Avatar
 
Join Date: Aug 2005
Location: Raleigh, NC
Posts: 1,969
Quote:
Originally Posted by jhebert View Post
CEL popped last night, you were right
Post back your results after changing the T-stat.
rodneyiii is offline  
post #7 of 9 Old 01-02-2013, 11:35 AM Thread Starter
jhebert
Member
 
Join Date: Dec 2012
Posts: 30
(Thread Starter)
According to my OBD the hottest the coolant was measuring was 180 ish, dealer is switching tstat now will report back.

Sent from my SAMSUNG-SGH-I747 using AutoGuide.Com Free App
jhebert is offline  
post #8 of 9 Old 01-07-2013, 11:15 PM Thread Starter
jhebert
Member
 
Join Date: Dec 2012
Posts: 30
(Thread Starter)
Took 4 days since apparently a blower valve or baffle or something on the intake manifold was rattling and they had to replace the whole manifold to fix it. Didnt really care bc they were paying 100% (bought less than 30 days ago).

Regardless, it was my thermostat HOUSING that was broken, replaced and now needle is dead center and obd reads 199.9 coolant temp

Sent from my SAMSUNG-SGH-I747 using AutoGuide.Com Free App
jhebert is offline  
post #9 of 9 Old 01-08-2013, 02:01 PM
rodneyiii
Senior Member
 
rodneyiii's Avatar
 
Join Date: Aug 2005
Location: Raleigh, NC
Posts: 1,969
Glad you got it fixed - for FREE!
rodneyiii is offline  
Sponsored Links
Advertisement
 
Reply

  Dodge Charger Forums > Dodge Charger Discussion > Charger Problems/Assistance

Quick Reply

User Tag List

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode


Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone have oil temp an trans temp gauges? PLEASE READ Hemidude23 General Charger Discussion 2 07-22-2011 07:32 PM
running temp jtrepina Charger Problems/Assistance 13 06-20-2009 03:40 PM
Water temp or Oil temp? Racin67Chevy General Charger Discussion 9 06-15-2009 12:21 PM
Temp running high after pred tune..whats up?? MzGudz General Charger Discussion 1 11-02-2008 06:15 AM
Average Running Temp? PythonSRT8 Charger SRT-8 Discussion 26 01-17-2007 07:43 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

 
For the best viewing experience please update your browser to Google Chrome