cruise control help?? [Archive] - Dodge Charger Forums

: cruise control help??


gamerzgalore
04-10-2010, 01:16 AM
I feel extremely dumb asking this question, but I cant seem to get the cruise control for my 2006 dodge charger RT to work :confused::confused:! I recently purchased the car used, and it didn't come with the manual ( ordering one from dodge this week). Can anyone give me a short run down of how to set the cruise control? I can get it to set 2 out of 10 attempts, but not consistently.

rdsabin1
04-10-2010, 05:47 AM
Here is a link to the Dodge Owners Web site where you can download the owners manual. http://www.dodge.com/en/owners/manuals/index.html?

GLHS837
04-10-2010, 07:57 AM
Okay, in case thats not working, its like this.

1. Press stalk in towards the column, odd move, but thats what you do. It should at that point give you the cruise symbol on the dash, and the stalk has a small yellow light that turns on.

2. Pull stalk towards you, that sets the speed at your current speed.

hskr
04-10-2010, 09:18 AM
Also, if it's anything like my past Dodge cars, you can't set the cruise below 35mph or above 80 or 90mph.

GLHS837
04-10-2010, 11:11 AM
SRT cruise should be good up to top end. There was some heartache early on, when Dieter was being run around on the autobahn in a 300c SRT, chauffeur set cruise smewhere above 150, didnt work right. That cause a TSB to reporgram them for 2005 SRTs, and was incorporated for all of them after that.

keviiinn
04-11-2010, 10:11 PM
so there's suppose to be a light on the dash for cruise control? I actually don't get any dash light. where is it suppose to be? I just get the light on the stalk.

GLHS837
04-12-2010, 05:12 AM
Maybe if you dont have EVIC you dont get it. Not a light, an indication, looks like a speedo dial.

keviiinn
04-12-2010, 06:13 AM
Maybe if you dont have EVIC you dont get it. Not a light, an indication, looks like a speedo dial.

That's the thing. I do have the EVIC. I will go take a look and see if I can get the dash light to come on by turning the key to on. My cruise does actually work though even without the light

edit: ok I just went out to check it. there is no cruise control indicator icon in the gauge cluster. I even shone a flashlight at the icons so I could see if there was a cutout location for the light to come on, and it's not there. was this added after the 06 models?

mnunes
04-12-2010, 08:54 AM
On mine, there was no indication of any kind on the EVIC when cruise was on or off. I had a flash done to the cluster and now it shows the text "CRUISE ON" and "CRUISE OFF" for a few seconds when I change modes.

GLHS837
04-12-2010, 09:08 AM
Page 133/134/135 of the 2006 owners manual. Page 162 of the 2008 manual. Page 172 of the 2009, Shows the indication. Under the tach. Called the "Electronic Speed Control Indicator Light" Its number 4 in the illustrations.

mnunes
04-12-2010, 10:17 PM
Page 133/134/135 of the 2006 owners manual. Page 162 of the 2008 manual. Page 172 of the 2009, Shows the indication. Under the tach. Called the "Electronic Speed Control Indicator Light" Its number 4 in the illustrations.

Interesting. it must have been a running change in the 2006 model year because my instrument cluster doesn't have an indicator for it and it's not mentioned in my owner's manual.

AKCallahan
04-13-2010, 12:52 AM
BOTH of my 2006 Chargers have a speedometer (as mentioned above) with an arrow pointing to a tick mark on the light. It's hard to explain but I can't actually take a picture if you can't figure this one out. But also as mention..push the outer part of the crusie control stick toward the inside of the car. This DOESN'T set the cruise, just turns it one. Then pull it toward you, like you do the turn signal stick to flash your bright lights, and this sets your cruise. When you tap the stick up, you accelerate by 2mph (I believe). If you have broken cruise via the brake pedal, tapping the stick up RESUMES the speed at which you set it. Pushing the stick out, like you do to the turn signal stick to turn the highbeams on, will cancel the cruise speed. Tapping this stick down while on cruise, drops your cruise speed 2mph (or so).

http://z.about.com/d/cars/1/0/V/y/ag_07superbee_turnsignals.jpg

GLHS837
04-13-2010, 05:08 AM
Interesting. it must have been a running change in the 2006 model year because my instrument cluster doesn't have an indicator for it and it's not mentioned in my owner's manual.


I'll pull the 2005 300C manual, that would show the 2005 indicators, I think.

GLHS837
04-13-2010, 05:17 AM
Sure enough, just looked over the 2005 Magnum manual. No cruise indication. Hmm, so looks like we need to figure out the cut in date for that.

I'll start a poll/thread later this am.

Part Deux
04-13-2010, 07:02 AM
The tap up and down changes the speed on the charger 1mph. Unlike the PT, which seems to have a percentage speed change.

hskr
04-13-2010, 07:22 AM
The tap up and down changes the speed on the charger 1mph. Unlike the PT, which seems to have a percentage speed change.


It has to be in the computer programming. On my truck, accell increases by 2mph, but decell only drops 1mph.

mnunes
04-14-2010, 11:11 PM
Sure enough, just looked over the 2005 Magnum manual. No cruise indication. Hmm, so looks like we need to figure out the cut in date for that.

I'll start a poll/thread later this am.

My guess is that they changed it around Oct/Nov 2006 when they changed the auto-down windows. Prior to Oct/Nov 2006 they were auto-down only for the driver. After that they added auto-up/auto-down for both driver and passenger sides. I think that's also when they made auto-headlights standard with automatic climate control. Sounds like the perfect time to do other electronics changes. :)